搜档网
当前位置:搜档网 › CCNPv6_ROUTE_Lab2-7_EIGRP_Troubleshooting_Instructor

CCNPv6_ROUTE_Lab2-7_EIGRP_Troubleshooting_Instructor

CCNPv6_ROUTE_Lab2-7_EIGRP_Troubleshooting_Instructor
CCNPv6_ROUTE_Lab2-7_EIGRP_Troubleshooting_Instructor

CCNPv6 ROUTE

Chapter 2 Lab 2-7, Troubleshooting EIGRP Instructor Version

Topology

Objective

?Troubleshoot EIGRP configurations.

Background

In this lab, you troubleshoot existing configurations to achieve a working topology. You use troubleshooting techniques to correct anything in the scenario that prevents full IP connectivity. Full IP connectivity means that every IP address in the scenario should be reachable from every router. If you do not know where to start, try pinging remote addresses and see which ones are reachable (either manually performing pings or using a Tcl script).

Note: This lab uses Cisco 1841 routers with Cisco IOS Release 12.4(24)T1 and the advanced IP services image c1841-advipservicesk9-mz.124-24.T1.bin. You can use other routers (such as a 2801 or 2811) and Cisco IOS Software versions if they have comparable capabilities and features. Depending on the router model and Cisco IOS Software version, the commands available and output produced might vary from what is shown in this lab.

Required Resources

? 4 routers (Cisco 1841 with Cisco IOS Release 12.4(24)T1 Advanced IP Services or comparable)

?Serial and console cables

Requirements

?Use the IP addressing scheme shown in the diagram.

?All routers must participate in EIGRP AS 1.

?All networks in the diagram must be in EIGRP AS 1.

?Do not use any static routes, default routes, or other routing protocols.

?All IP addresses in the topology must be reachable from all routers. Initial Configurations

Copy and paste the initial configurations into your routers.

Router R1

hostname R1

!

interface Loopback0

ip address 10.1.1.1 255.255.255.0

!

interface Serial0/0/0

ip address 172.16.21.1 255.255.255.0

clock rate 64000

bandwidth 64

no shutdown

!

router eigrp 1

network 10.1.1.0 0.0.0.255

network 172.16.12.0 0.0.0.255

auto-summary

end

Router R2

hostname R2

!

interface Loopback0

ip address 172.16.2.1 255.255.255.0

!

interface Serial0/0/0

ip address 172.16.12.2 255.255.255.0

bandwidth 64

no shutdown

!

interface Serial0/0/1

ip address 172.16.23.2 255.255.255.0

clock rate 64000

bandwidth 64

no shutdown

!

router eigrp 1

network 172.16.2.0 0.0.0.255

network 172.16.12.0 0.0.0.255

network 172.16.23.0 0.0.0.255

no auto-summary

end

Router R3

hostname R3

!

interface Loopback0

ip address 172.16.3.1 255.255.255.0 !

interface Serial0/0/1

ip address 172.16.23.3 255.255.255.0 bandwidth 64

no shutdown

!

interface Serial0/1/0

ip address 172.16.34.3 255.255.255.0 clock rate 64000

bandwidth 64

no shutdown

!

router eigrp 1

network 172.16.23.0 0.0.0.255

network 172.16.30.0 0.0.0.255

network 172.16.34.0 0.0.0.255

no auto-summary

end

Router R4

hostname R4

!

interface Loopback0

ip address 10.1.4.1 255.255.255.0

!

interface Serial0/0/0

ip address 172.16.34.4 255.255.255.0 bandwidth 64

no shutdown

!

router eigrp 100

network 10.1.4.0 0.0.0.255

network 172.16.34.0 0.0.0.255

auto-summary

end

Notes: ______________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________ ____________________________________________________________________________________

Router Interface Summary Table

EIGRP Troubleshooting Lab Answer Key (Instructor version)

Getting Started

This answer key addresses how to troubleshoot the various problems in the lab. It starts with one of the

obvious problems, which sends error messages to the console. However, for other problems, start by making sure that all adjacencies are up and that all remote addresses are reachable.

Problem 1: IP Address Mismatch

On R1 and R2, you might see error messages like the following after the initial configurations are entered.

Here, the router is explicitly indicating that the IP addresses in the hello packets do not match up to the same subnet.

R1#

*May 7 03:07:52.995: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 172.16.12.2 not on common subnet for Serial0/0/0

R2#

*May 7 03:05:41.767: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 172.16.21.1 not on common subnet for Serial0/0/0

The show ip eigrp neighbors command on R1 confirms that R1 has not formed a neighbor adjacency with R2.

R1# show ip eigrp neighbors

IP-EIGRP neighbors for process 1

Verify IP addressing using the show ip interface brief command on both routers.

R1# show ip interface brief

Interface IP-Address OK? Method Status

Protocol

FastEthernet0/0 unassigned YES unset administratively down down FastEthernet0/1 unassigned YES unset administratively down down Serial0/0/0 172.16.21.1 YES manual up up Serial0/0/1 unassigned YES unset administratively down down Serial0/1/0 unassigned YES unset administratively down down Serial0/1/1 unassigned YES unset administratively down down wlan-controller1/0 unassigned YES unset administratively down down Loopback0 10.1.1.1 YES manual up up R2# show ip interface brief

Interface IP-Address OK? Method Status

Protocol

FastEthernet0/0 unassigned YES unset administratively down down FastEthernet0/1 unassigned YES unset administratively down down Serial0/0/0 172.16.12.2 YES manual up up Serial0/0/1 172.16.23.2 YES manual up up Serial0/1/0 unassigned YES unset administratively down down Serial0/1/1 unassigned YES unset administratively down down Loopback0 172.16.2.1 YES manual up up

By comparing their IP addresses on that link, you can see that the R1 IP address does not match the address in the diagram. When you change the R1 IP address to the correct one, the adjacency should form.

R1(config)# interface serial0/0/0

R1(config-if)# ip address 172.16.12.1 255.255.255.0

Problem 2: R3-R4 Neighbor Adjacency

When using ping, the R4 routes are not reachable from routers R1, R2, and R3. If you look at their individual routing tables, the R4 routes are not there. Verify that all neighbor adjacencies are up using the show ip eigrp neighbors command. You will see that R3 and R4 do not have each other in their neighbor tables.

R3# show ip eigrp neighbors

IP-EIGRP neighbors for process 1

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 172.16.23.2 Se0/0/1 13 02:09:59 16 200 0 85

R4# show ip eigrp neighbors

IP-EIGRP neighbors for process 100

What is interesting here is the first line of the output: The process numbers do not match up. One of the rules of EIGRP adjacencies is that the AS numbers must match for an adjacency to form. Because the requirement is to put all routers in EIGRP AS 1, R4 must change. An easy way to change EIGRP AS numbers is to copy and paste the old EIGRP configuration to a new AS number. The highlighted lines below is the part that has been copied.

R4# show run | section eigrp

router eigrp 100

network 10.1.4.0 0.0.0.255

network 172.16.34.0 0.0.0.255

auto-summary

R4#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R4(config)# no router eigrp 100

R4(config)# router eigrp 1

R4(config-router)# network 10.1.4.0 0.0.0.255

R4(config-router)# network 172.16.34.0 0.0.0.255

R4(config-router)# auto-summary

Problem 3: R3 Loopback Not Reachable

When testing connectivity, you will find out that the R3 loopback is not reachable. The routing table indicates that there is no route for it.

R2# ping 172.16.3.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R2# show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets

D 172.16.34.0 [90/2681856] via 172.16.23.3, 02:21:33, Serial0/0/1

C 172.16.23.0 is directly connected, Serial0/0/1

C 172.16.12.0 is directly connected, Serial0/0/0

C 172.16.2.0 is directly connected, Loopback0

D 10.0.0.0/8 [90/2297856] via 172.16.12.1, 00:04:21, Serial0/0/0

However, the R2 routing table has a route from R3 (highlighted), so the issue might be on R3. Looking on R3, the loopback interface is configured with the correct IP address.

R3# show ip interface brief

Interface IP-Address OK? Method Status

Protocol

FastEthernet0/0 unassigned YES unset administratively down down FastEthernet0/1 unassigned YES unset administratively down down Serial0/0/0 unassigned YES unset administratively down down Serial0/0/1 172.16.23.3 YES manual up up Serial0/1/0 172.16.34.3 YES manual up up Serial0/1/1 unassigned YES unset administratively down down Loopback0 172.16.3.1 YES manual up up

The next step is to verify whether EIGRP is including the network in its process. A quick way to do this is with the show run command and the section modifier command.

R3# show run | section eigrp

router eigrp 1

network 172.16.23.0 0.0.0.255

network 172.16.30.0 0.0.0.255

network 172.16.34.0 0.0.0.255

no auto-summary

The loopback network is not in the configuration. However, the configuration has a network that is not even a part of the topology (highlighted). Change this network statement in EIGRP to fix the problem.

R3(config)# router eigrp 1

R3(config-router)# no network 172.16.30.0 0.0.0.255

R3(config-router)# network 172.16.3.0 0.0.0.255

Problem 4: R1 and R4 Loopbacks Not Reachable

This is the trickiest problem in the lab. Similar to the R3 loopback, the R1 and R4 loopbacks are not reachable from all routers. On R2 or R3, try pinging both.

R2# ping 10.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/30/36 ms

R2#ping 10.1.4.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.4.1, timeout is 2 seconds:

U.U.U

Success rate is 0 percent (0/5)

One works, but not the other. Check the routing table to see if there are routes for each router. The U.U.U in the ping output indicates that the packets are getting sent somewhere and the unreachable messages are coming back.

R2# show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 5 subnets

D 172.16.34.0 [90/2681856] via 172.16.23.3, 02:35:38, Serial0/0/1

C 172.16.23.0 is directly connected, Serial0/0/1

C 172.16.12.0 is directly connected, Serial0/0/0

C 172.16.2.0 is directly connected, Loopback0

D 172.16.3.0 [90/2297856] via 172.16.23.3, 00:05:26, Serial0/0/1

D 10.0.0.0/8 [90/2297856] via 172.16.12.1, 00:18:27, Serial0/0/0

A route exists in the routing table that would cover both loopbacks. However, the R1 loopback is accessible through one interface of the router and the R4 loopback is through a different interface. Something must be wrong. If you check the routing table on R3, it has the same route, but it is going in the other direction.

R3# show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 5 subnets

C 172.16.34.0 is directly connected, Serial0/1/0

C 172.16.23.0 is directly connected, Serial0/0/1

D 172.16.12.0 [90/2681856] via 172.16.23.2, 02:46:59, Serial0/0/1

D 172.16.2.0 [90/2297856] via 172.16.23.2, 02:46:59, Serial0/0/1

C 172.16.3.0 is directly connected, Loopback0

D 10.0.0.0/8 [90/2297856] via 172.16.34.4, 00:29:47, Serial0/1/0

The routes are classful summaries of the entire 10.0.0.0/8 network. With your knowledge of EIGRP, you could figure out that EIGRP is automatically summarizing these networks. Auto-summarization is an issue when you have a discontinuous major network, like in this scenario. To resolve it, disable auto-summarization on all routers (auto-summarization should already be disabled on R2 and R3).

R1(config)# router eigrp 1

R1(config-router)# no auto-summary

R4(config)# router eigrp 1

R4(config-router)# no auto-summary

You should now have full IP connectivity. Test this using the Tcl script on all routers.

TCL Verification Script

R1# tclsh

foreach address {

10.1.1.1

172.16.2.1

172.16.3.1

10.1.4.1

172.16.12.1

172.16.12.2

172.16.23.2

172.16.23.3

172.16.34.3

172.16.34.4

} {

ping $address }

Device Configurations

Router R1

hostname R1

!

interface Loopback0

ip address 10.1.1.1 255.255.255.0

!

interface Serial0/0/0

ip address 172.16.12.1 255.255.255.0

clock rate 64000

bandwidth 64

no shutdown

!

router eigrp 1

network 10.1.1.0 0.0.0.255

network 172.16.12.0 0.0.0.255

no auto-summary

end

Router R2

hostname R2

!

interface Loopback0

ip address 172.16.2.1 255.255.255.0

!

interface Serial0/0/0

ip address 172.16.12.2 255.255.255.0

bandwidth 64

no shutdown

!

interface Serial0/0/1

ip address 172.16.23.2 255.255.255.0

clock rate 64000

bandwidth 64

no shutdown

!

router eigrp 1

network 172.16.2.0 0.0.0.255

network 172.16.12.0 0.0.0.255

network 172.16.23.0 0.0.0.255

no auto-summary

end

Router R3

hostname R3

!

interface Loopback0

ip address 172.16.3.1 255.255.255.0 !

interface Serial0/0/1

ip address 172.16.23.3 255.255.255.0 bandwidth 64

no shutdown

!

interface Serial0/1/0

ip address 172.16.34.3 255.255.255.0 clock rate 64000

bandwidth 64

no shutdown

!

router eigrp 1

network 172.16.3.0 0.0.0.255

network 172.16.23.0 0.0.0.255

network 172.16.34.0 0.0.0.255

no auto-summary

end

Router R4

hostname R4

!

interface Loopback0

ip address 10.1.4.1 255.255.255.0

!

interface Serial0/0/0

ip address 172.16.34.4 255.255.255.0 bandwidth 64

no shutdown

!

router eigrp 1

network 10.1.4.0 0.0.0.255

network 172.16.34.0 0.0.0.255

no auto-summary

end

相关主题