搜档网

搜档网

当前位置:搜档网 > ALLEGRO使用教程

ALLEGRO使用教程

ALLEGRO使用教程

一.PCB窗口介面介绍

ALLEGRO使用教程

运行PCB EDIT 出现对话框

ALLEGRO使用教程

注:不同的选项能实现的功能有所不同,一般PCB画板时选择Allegro Expert

1.PCB介面

ALLEGRO使用教程

2.工具栏

其中工具栏的图标在相应的菜单栏中都可以找到,其对应关系如下:红色的文字对应菜单栏的选项。

ALLEGRO使用教程

如果工具栏图标太多或者太少,可以通过菜单View=>Customization=>Toolbar 自己增加或者减少一些不常用的图标

ALLEGRO使用教程

3.控制栏说明

控制栏主要有三大选择项:Option、Find 和Visibility通过控制面板的Option 标签可选择被激活的类或子类,在Allegro 数据库中,所有元素都有一个类属性

(CLASS)或子类属性(SUBCLASS)。通过控制面板的Find 标签,可以选择各种元素,如Nets、Lines、Vias等,当执行各种命令时,都需要在Find 标签中选择好相应的元素。以移动命令为例,说明一下“Find”选项含义。选择菜单Edit=>Move,再看“Find”选项如图所示,

其中有多个复选框可供选择,想移动什么东西,一定要将其对应的复选框钩上“√”,比如,如果想要移动元件,

首先点击一下“All Off”按钮,关闭所有的复选框,然后再将复选框“Symbols”钩上“√”,就可以对元件进

行移动了。

ALLEGRO使用教程

ALLEGRO使用教程

如果要查看某个元件的信息,可以通过Display->Element,或单击图标,然后在

Find 标签中选择好相应的元素。通过控制面板的Visibility 标签,可以选择Etch 、Pin、Via、DRC 的各个子类的可视性。“Visibility”下的“Views”可以用于快速切换窗口显示,其中的列表项内容是在进行过光绘的输出设置之后,就可以显示出来。

“Visibility”下的“layer”的意思就是对各层进行打开或者关闭显示,将小方框里打上“√”表示打开这层的显示,取消“√”表示不显示该层。

ALLEGRO使用教程

4. 缩略图和状态栏说明

ALLEGRO使用教程

5. 命令输入窗口说明

绝大多数的Allegro的菜单中的命令都有相对应的命令名字,我们可以通过在命令行中输入相应的“名字+回车”,可以和通过鼠标点击相应的命令达到一样的效果。比如,要移动元件,可以输入“move”然后回车即可。

ALLEGRO使用教程

6.颜色设置窗口说明

所有EDA软件都是分层管理的,每个层都代表不同的意义,每个层都可以加以颜色区分,可以打开或者关闭其显示。打开颜色设置层是通过菜单Display=>Color/Visibility 命令或者

点击工具栏图标:“”。在Allegro里的设计文件可以包含很多不同的层面,每个层面在板子上对应一个SubClass,又把一定关系的SubClass 归类为一个Class,同样把一些一定关系的Class 归类为一个Group,主要分成7 个Group:

Geometry

Stackup

Components

Manufacturing

Areas

Analysis

Display

Allegro在操作打开和关闭每个层面都很方便快捷。但铜箔不能单独成为一个Class,所以走线和铜箔必须同时显示,或者同时关闭。一些常用的层需要打开并加以颜色区分,比如,边框层、尺寸标注、丝印、焊盘、走线层等等。颜色可以根据个人的习惯进行设置,采用默认设置是不可取的,因为Allegro 所有层的默认设置都是一种颜色。关于颜色设置的操作步骤可参看实例:颜色

ALLEGRO使用教程

二.制作板外框、叠层和版图设置

1. 设置工作区

选择菜单目录Setup=>Drawing Size 打开Drawing Parameters 设置窗口,参照下图进行设

置:

ALLEGRO使用教程

如果整板图框所定原点为:(0,0),屏幕的左下角坐标(-50,-50);左上角坐标(-50,300);右上角坐标(450,300);右下角坐标(450,-50),这样宽度就是500mm,高度为350mm,根据这个尺寸就能在Drawing Extents 中进行设置了,如图所示,将Left X、Lower Y、Width、

Height 设成相应的值。

ALLEGRO使用教程

2. 通过ADD菜单绘制边框

在工作区设置好之后就可以选择命令Add=>Line 或者点击工具栏图标“”来绘制边框了,注意一下“Option”中的参数的设置,一定要选择Board Geometry 和Outline,具体的图示见下图的参数说明:

ALLEGRO使用教程

在参数设好之后,我们采用输入坐标的方式精确绘制板框,一般要求PCB 的左下角为原点(0,0),这样大家的尺寸能一致,修改比较方便。下面举例说明:根据结构图计算出PCB 右下角坐标将是(200,0);右上角坐标将是(200,128);左上角坐标将是(0,128)。绘制步骤如下:

注:如果结构提供DXF文件可以根据提供的DXF文件设置板框

1)选择命令Add=>Line 或者点击工具栏图标“”

2 )设置“Option”的参数

3 )鼠标点击命令输入窗口,输入字符:“x 0 0”(x 空格0 空格0 回车键),注意空格和小写字符,引号

不必输入,每次命令输入之后一定加回车键确认执行该命令。

4 )X 轴方向增量200mm,输入字符:“ix 200”,注意不要理会鼠标的位置

5 )Y 轴方向增量128mm,输入字符:“iy 128”

6 )X 轴方向增量-200mm,输入字符:“ix -200”

7 )Y 轴方向增量-128mm,输入字符:“iy -128”

8 )点击右键,选择Done 结束命令

3. 边框倒角

结构图可能没有提出要四周倒角,但是,通常PCB 都要将边缘进行倒圆角处理,这样可以在搬运过程中减少尖角划破皮肤、衣服或机柜表漆等等。倒角方式有两种:圆角和45度角。其菜单命令分别为:

Manufacture=>Dimension/Draft=>Chamfer 和Manufacture=>Dimension/Draft=>Fillet。参数设置分别为:

ALLEGRO使用教程

4.添加叠层

Allegro 系统默认的PCB 板都是两层板,这块板我们需要调整到4 层层压结构,即在TOP 层和BOTTOM层中间添加GND 层和VCC 层添加层数的命令是Setup=>Cross-section

或者点击工具栏图标“”也可以,打开的窗口如下:

ALLEGRO使用教程

5. 设置栅格

打开Setup->Grid,布局时,栅格设为100mil、50mil或25mi;,布线时,栅格可设为5mil。三.布局及布局后的设置

1.快速布局

第一种方式的执行菜单命令为:Place=>Quickplace

Edge 的4个参数表示与PCB 边框放置的位置:上、下、左和右。

Side 的两个参数表示放置在顶层还是底层。

Place all components表示将所有元件一起放进来,上边的3个参数表示有选择的放入。Unplaced symbol count 表示未放进来的元件的个数,通常没有放进来的元件一般是由两个原因造成的:

1. 元件的焊盘不正确或者没有

2. 当前的工作区域过小,元件摆不下

ALLEGRO使用教程

打开PCB 的Place=>Manually 窗口,并一直保持打开状态

ALLEGRO使用教程

选择对话框中其中一个器件,将鼠标移至工作窗口放置器件。注:器件要放置后再点OK按钮

2.移动元件

在布局的工程中会用到移动和旋转元件, 结构图给出的尺寸都是以元件中心定位的,但当我们想精确地放置某个元件的时候,最好不要以元件的中心

为参考点移动和定位元件,因为,Cadence 元件库的中心和结构图给出的器件的中心不一定是一致的,很容易搞错。通常都是以元件的某个管脚来定位的,一般习惯选用第一脚来定位,也可以选用其它脚,但元件的安装孔则不能选用(没有管脚名)。通过计算得知X7的第一脚的坐标为(61.825 ,5.02),下面就以X7 的第一脚的坐标来精确放置该元件,

其步骤如下:

1. 打开Place=> Manually 窗口(或者点击工具栏图标“”),从“Components by refdes”列表中找到并选中X7,然后将X7调入到板内

2. 点击“OK”按钮关闭placement 窗口

3. 运行Edit=>Move 命令或者点击工具栏图标“”

4. 将右边移动命令的参数设置一下,“Find”列表中仅将“Symbols”前面的小方框打上钩(表示选中),其它的都不要选中;“Option”列表的“Point”的下拉列表项中,将“Sym Pin #”选中,同时,在下面弹出的“Symbol pin #:”中填入数字“1”(通常默认是1)

5. 点击X7 元件,再点击屏幕底下的命令输入行,输入如下命令:“x 61.825 15.02”回

车确认

6. 点击右键Done 结束命令

ALLEGRO使用教程

旋转元件分两种方式:固定式和移动式。

固定式:元件不动,运行Edit=>Spin 命令,仅将元件旋转某个角度,右边参数可以设定旋转中心点和转角;状态栏可以动态显示当前旋转的角度。

移动式:在移动元件的同时右键选择“Rotate”命令,边移动边调整方向,参数设置、状态栏动态显示与固定式一样。

3. 高亮显示电源和地网络

不同的电源或者地网络高亮以不同的颜色,使该板的电源分布状态一目了然,便于布线和分

割电源平面和地平面。其命令为:Display=>Hilight 或者点击工具栏图标“”,参数设置窗口如下:

ALLEGRO使用教程

Option 的参数选项变成了颜色的列表,我们可以根据需要选择不同的颜色,以GND 和VCC3.3V 为

例讲述一下高亮网络的步骤,其步骤如下:

1. 选择命令Display=>Hilight 或者点击工具栏图标“”

2. 右边“Option”选择深红色“”按钮

3. 右边“Find”仅选择Nets 按钮(只高亮网络)

4. 在右下部“Find by Name”中,将类型选择为“Net”在下面的文本框中输入“GND”回车(也可以点击More 按钮在列表中查找;最直接的方法是直接点击GND 网络的元件焊盘即可,前提是清楚哪个元件的焊盘是GND网络)

5. 右边“Option”选择浅蓝色“”按钮

6. 在右下部“Find by Name”中输入“VCC3.3V”回车

7. 右键Done 结束命令

4. 约束管理器的设置

约束管理器是每一块板必须设置的一项内容,主要是对整板的DRC 规则,即线宽、线距

和过孔大小进行设置,其命令在菜单Setup=>Constraints 或者点击工具栏图标“”也可以,打开的约束管理器设置窗口如下:

ALLEGRO使用教程

点击间距设置Spacing rule set 的“Set values”弹出窗口如下:

ALLEGRO使用教程

点击线宽设置Physical(lines/vias)rule set 的“Set values”弹出窗口如下:

ALLEGRO使用教程

这面主要讲一下三个方面内容:

1. 普通线宽和线距

普通线宽和线距设置

普通线宽和线距根据每块板的密度和性能不同设置的数值也不尽相同,通常线宽和线距设成0.2032mm/0.2032mm, 也就是英制的8mil 即可;对于密度高的板可以设置成0.1524mm/0.1524mm (英制6mil),对于电源板设置成0.5mm/0.5mm 都有可能。具体的设置步骤如下:

1 ) 运行命令Setup=>Constraints 或者点击工具栏图标“”

2 ) 点击间距设置的“Set values”按钮

3 ) 将值参照图3.8所示的内容设置一下

4 ) 点击Ok 按钮关闭线距设置窗口

5 ) 点击线宽设置的“Set values”按钮

6 ) 将“Min line width”值设成0.2

7 ) 将“Min neck width”值设成0.2(不对瓶颈线宽进行设置)

8 ) 将“Max neck length”值设成5mm

9 ) 在过孔列表中选择“VIA”(如果列表中没有想要的值,可以在下面的文本框中输入相应的过孔文件名,然后点击“Add”按钮添加到列表中。)

10 ) 点击Ok 按钮关闭线宽设置窗口

11 ) 点击Ok 按钮关闭约束管理器设置窗口

2. 电源线宽

普通线宽和线距设置好之后还要对该板的电源线进行设置,通常设置成0.5mm 即可

具体的设置步骤如下:

1 )运行命令Setup=>Constraints 或者点击工具栏图标“”

2 )间距设置还是与默认设置一样,不必改变

3 )点击线宽设置的“Set values”按钮

4 )在第一个文本框中输入名称

“POWER”(表示是电源或者GND),然后点击左边的“Add”按钮添加到Constraint Set Name 列表中,这时,Constraint Set Name 列表的名称已经变成“POWER”了。

5 )将“Min line width”值设成0.5 (先将所有层设成0.5mm)

6 )将“Min neck width”值设成0.28 (QFP,QFN封装焊盘较小,因此在这要设置)

7 )将“Max neck length”值设成5mm

8 )在Subclass 列表框里选择TOP,对顶层进行特殊设置

9 )将“Min line width”值设成0.28(这样仅顶层设为0.28mm,内层和底层还是0.5mm)

10 )点击Ok 按钮关闭线宽设置窗口

11 )点击Ok 按钮关闭约束管理器设置窗口

电源的线宽设好之后,还要将电源的“Power”的属性添加到电源网络当中,顺便也将电源网络的飞线属性也加上。由于电源信号的网络较多,而且都有单独的电源平面层供电,走线的时候只是将SMD 电源的管脚拉出一根线打个Via 就可以连接上,通常时候不必将其飞线显示出来,对于没有连接的电源管脚仅将飞线

ALLEGRO使用教程

显示成如上图所示这种的状态就可以,打叉的小方框表示还没有连接的状态,这样可以去掉一些不必要显示的飞线,使整板看上去简单明了一些。

定义电源网络属性的命令在菜单Edit=>Properties 中,其打开的窗口如下:

ALLEGRO使用教程

添加电源属性和定义电源飞线属性操作步骤如下:

1 )运行命令Edit=>Properties

2 )右边的“Find”参数仅选择“Nets”参数(其它都不选)

3 )选择VCC3.3V 网络,各项属性参数参照下图3.11 进行设置

ALLEGRO使用教程

4 )点击Ok 按钮关闭属性设置窗口

5 )重复1、2步骤

6 )选择GND 网络,各项属性参数参照图3.11进行设置,V oltage 改成“0v”

7 )点击Ok 按钮关闭属性设置窗口

8 )右键选择Done 结束命令

9 )点击工具栏图标“”打开飞线显示,电源网络和地应该变成如图所示。3. 差分线宽和线距

定义差分属性的命令在菜单Logic=>Assign Differential Pair 中,其打开窗口如下:

ALLEGRO使用教程

5.电源和GND的划分

在布线之前需要对模拟电源和模拟GND 等进行大致划分,这样方便布线,已知这块板分模拟区和数字区我们需要将这两个区在电源层和GND 层隔离,让其间距为5mm。再做电源分隔之前需要在板上加一个布线区域,即Route Keepin,所有的走线和电源的铜箔都要在这个范围内,这一步是必须要做的,整个操作的步骤如下:

1 )首先打开相应的层,即Stack-Up=>Anti Etch 所有层和Area=>Route Ki 层

2 )选择命令Edit=>Z-Copy,参数照下图设置:

ALLEGRO使用教程

3 )鼠标点选一下边框,将Route Keepin 区域加上

4 )选择命令Add=>Line 或者点击工具栏图标“”参数参照下图3.19进行设置

ALLEGRO使用教程

5 )在PCB 中走一段宽为5MM的线将GND 和GNDA分开(线头一定要拉出板外)

6 )右键Done 结束命令

7 )选择命令Add=>Line 或者点击工具栏图标“”,参数参照下图进行设置

ALLEGRO使用教程

8. 在PCB 中走一段宽为5MM的线将VCC3.3V和VDD 分开(线头一定要拉出板外)

9. 右键Done 结束命令

10. 选择命令:Edit=>Split plane=>Create

11. 首先选择GND 层进行分割,在右下角的略缩图中可以得知当前的区域范围,分别选择GND 网络和GNDA网络