搜档网
当前位置:搜档网 > H3C三层交换机配置实例

H3C三层交换机配置实例

H3C三层交换机配置实例

1 网络拓扑图 (1)

2 配置要求 (1)

3划分VLAN并描述 (2)

3.1进入系统视图 (2)

3.2 创建VLAN并描述 (2)

4 给VLAN设置网关 (3)

4.1 VLAN1的IP地址设置 (3)

4.2 VLAN100的网关设置 (3)

4.3 VLAN101的网关设置 (3)

4.4 VLAN102的网关设置 (3)

4.5 VLAN103的网关设置 (4)

5 给VLAN指定端口,设置端口类型 (4)

5.1 VLAN100指定端口 (4)

5.2 VLAN102指定端口 (4)

5.3 VLAN1/101/103指定端口 (5)

6 配置路由协议 (6)

6.1 默认路由 (6)

6.2配置流分类 (6)

6.3 定义行为 (6)

6.4 应用QOS策略 (6)

6.5 接口配置QOS策略 (7)

1 网络拓扑图

H3C三层交换机配置实例

图1-1 网络拓扑图

2 配置要求

用户1网络:172.16.1.0/24 至出口1网络:172.16.100.0/24 用户2网络:192.168.1.0/24 至出口2网络:192.168.100.0/24实现功能:用户1通过互联网出口1,用户2通过互联网出口2。

3划分VLAN并描述

3.1进入系统视图

system-view //进入系统视图

H3C三层交换机配置实例

图3-1 系统视图

3.2 创建VLAN并描述

[H3C]vlan 1 //本交换机使用

[H3C-vlan1]description Manager //描述为“Manager”

[H3C-vlan1]quit

[H3C]vlan 100 //划分vlan100

[H3C-vlan100]description VLAN 100 //描述为“VLAN 100”[H3C-vlan100]quit

[H3C]vlan 101 //划分vlan101

[H3C-vlan101]description VLAN 101 //描述为“VLAN 101”[H3C-vlan101]quit

[H3C]vlan 102 //划分vlan102

[H3C-vlan102]description VLAN 102 //描述为“VLAN 102”[H3C-vlan102]quit

[H3C]vlan 103 //划分vlan103

[H3C-vlan103]description VLAN 103 //描述为“VLAN 103”[H3C-vlan103]quit

[H3C]

H3C三层交换机配置实例

图3-2 划分VLAN及描述

4 给VLAN设置网关

4.1 VLAN1的IP地址设置

把VLAN1的IP地址设置为192.168.0.254,子网掩码为255.255.255.0,用于本地使用。

[H3C]interface vlan-interface 1

[H3C-Vlan-interface1]ip address 192.168.0.254 255.255.255.0

[H3C-Vlan-interface1]quit

[H3C]

H3C三层交换机配置实例

图4-1 VLAN 1的IP设置

4.2 VLAN100的网关设置

把VLAN100的网关设置为192.168.100.254,子网掩码为255.255.255.0 。[H3C]interface vlan-interface 100

[H3C-Vlan-interface100]ip address 192.168.100.254 255.255.255.0

[H3C-Vlan-interface100]quit

[H3C]

H3C三层交换机配置实例

图4-2 VLAN100的网关设置

4.3 VLAN101的网关设置

把VLAN101的网关设置为192.168.1.254,子网掩码为255.255.255.0 。

[H3C]interface vlan-interface 101

[H3C-Vlan-interface101]ip address 192.168.1.254 255.255.255.0

[H3C-Vlan-interface101]quit

[H3C]

H3C三层交换机配置实例

图4-3 VLAN101的网关设置

4.4 VLAN102的网关设置

把VLAN102的网关设置为172.16.100.254,子网掩码为255.255.255.0 。

[H3C]interface vlan-interface 102

[H3C-Vlan-interface102]ip address 172.16.100.254 255.255.255.0 [H3C-Vlan-interface102]quit

[H3C]

H3C三层交换机配置实例

图4-4 VLAN102的网关设置

4.5 VLAN103的网关设置

把VLAN103的网关设置为172.16.1.254,子网掩码为255.255.255.0 。[H3C]interface vlan-interface 103

[H3C-Vlan-interface103]ip address 172.16.1.254 255.255.255.0 [H3C-Vlan-interface103]quit

[H3C]

H3C三层交换机配置实例

图4-5 VLAN103的网关设置

5 给VLAN指定端口,设置端口类型

5.1 VLAN100指定端口

将端口GigabitEthernet 1/0/1指定给vlan100,并配置端口模式。[H3C]interface GigabitEthernet 1/0/1

[H3C-GigabitEthernet1/0/1]port link-type access

[H3C-GigabitEthernet1/0/1]port access vlan 100

[H3C-GigabitEthernet1/0/1]speed 1000

[H3C-GigabitEthernet1/0/1]duplex full

[H3C-GigabitEthernet1/0/1]quit

[H3C]

H3C三层交换机配置实例

图5-1 VLAN100指定端口

5.2 VLAN102指定端口

将端口GigabitEthernet 1/0/2指定给vlan102,并配置端口模式。

[H3C]int G 1/0/2

[H3C-GigabitEthernet1/0/2]port link-type access

[H3C-GigabitEthernet1/0/2]port access vlan 102

[H3C-GigabitEthernet1/0/2]speed 1000

[H3C-GigabitEthernet1/0/2]duplex full

[H3C-GigabitEthernet1/0/2]quit

[H3C]

H3C三层交换机配置实例

图5-2 VLAN102指定端口

5.3 VLAN1/101/103指定端口

将端口GigabitEthernet 1/0/15~16指定给vlan1/101/101,并配置端口模式。[H3C]int G 1/0/15

[H3C-GigabitEthernet1/0/15]port link-type trunk

[H3C-GigabitEthernet1/0/15]port trunk permit vlan 1 101 103

[H3C-GigabitEthernet1/0/15]speed 1000

[H3C-GigabitEthernet1/0/15]duplex full

[H3C-GigabitEthernet1/0/15]quit

[H3C]int G 1/0/16

[H3C-GigabitEthernet1/0/16]port link-type trunk

[H3C-GigabitEthernet1/0/16]port trunk permit vlan 1 101 103

[H3C-GigabitEthernet1/0/16]speed 1000

[H3C-GigabitEthernet1/0/16]duplex full

[H3C-GigabitEthernet1/0/16]quit

[H3C]

H3C三层交换机配置实例

H3C三层交换机配置实例

图5-3 VLAN1/101/103指定端口

6 配置路由协议

6.1 默认路由

建立默认路由,将所有的数据包都丢往出口2的下一节点192.168.100.253:[H3C]ip route-static 0.0.0.0 0.0.0.0 192.168.100.253

6.2配置流分类

配置流分类1,对象为172.16.1.0/24的数据:

[H3C]acl number 3001

[H3C-acl-adv-3001]rule 0 permit ip source 172.16.1.0 0.0.0.255

[H3C-acl-adv-3001]quit

[H3C]traffic classifier 1

[H3C-classifier-1]if-match acl 3001

[H3C-classifier-1]quit

[H3C]

H3C三层交换机配置实例

图6-1 配置流分类1

6.3 定义行为

配置刚才定义的流分类的行为,定义如果匹配就下一跳至出口1即172.16.100.253:

[H3C]traffic behavior 1

[H3C-behavior-1]redirect next-hop 172.16.100.253

[H3C-behavior-1]quit

[H3C]

H3C三层交换机配置实例

图6-2 配置流分类行为

6.4 应用QOS策略

将刚才设置的应用至QOS策略中,定义policy 1:

[H3C]qos p 1

[H3C-qospolicy-1]classifier 1 behavior 1

[H3C-qospolicy-1]quit

[H3C]

H3C三层交换机配置实例

图6-3 QOS策略

6.5 接口配置QOS策略

在接口上应用定义的QOS策略policy 1:

[H3C]int G1/0/15

[H3C-GigabitEthernet1/0/15]qos apply policy 1 inbound [H3C-GigabitEthernet1/0/15]quit

[H3C]int G1/0/16

[H3C-GigabitEthernet1/0/16]qos apply policy 1 inbound [H3C-GigabitEthernet1/0/16]quit

[H3C]

H3C三层交换机配置实例

图6-4 在端口应用QOS策略

至此,配置已完成。保存配置。

save

H3C三层交换机配置实例

图6-5 保存配置

下载文档原格式(Word原格式,共9页)
相关文档
  • 三层交换机配置实例

  • h3c三层交换机配置

  • 三层交换机配置

  • h3c交换机常用配置

  • 配置三层交换机

  • 三层交换机配置案例