搜档网
当前位置:搜档网 > H3C交换机常用命令注释

H3C交换机常用命令注释

?
H3C交换机常用命令注释

H3C交换机常用命令注释
1、system-view 进入系统视图模式
2、sysname 为设备命名
3、display current-configuration 当前配置情况
4、 language-mode Chinese|English 中英文切换
5、interface Ethernet 1/0/1 进入以太网端口视图
6、 port link-type Access|Trunk|Hybrid 设置端口访问模式
7、 undo shutdown 打开以太网端口
8、 shutdown 关闭以太网端口
9、 quit 退出当前视图模式
10、 vlan 10 创建VLAN 10并进入VLAN 10的视图模式
11、 port access vlan 10 在端口模式下将当前端口加入到vlan 10中
12、port E1/0/2 to E1/0/5 在VLAN模式下将指定端口加入到当前vlan中
13、port trunk permit vlan all 允许所有的vlan通过

H3C路由器常用命令注释
1、system-view 进入系统视图模式
2、sysname R1 为设备命名为R1
3、display ip routing-table 显示当前路由表
4、 language-mode Chinese|English 中英文切换
5、interface Ethernet 0/0 进入以太网端口视图
6、 ip address 192.168.1.1 255.255.255.0 配置IP地址和子网掩码
7、 undo shutdown 打开以太网端口
8、 shutdown 关闭以太网端口
9、 quit 退出当前视图模式
10、 ip route-static 192.168.2.0 255.255.255.0 192.168.12.2 description
To.R2 配置静态路由
11、 ip route-static 0.0.0.0 0.0.0.0 192.168.12.2 description To.R2 配置
默认的路由
H3C S3100 Switch
H3C S3600 Switch
H3C MSR 20-20 Router
小 技 巧
1、调整超级终端的显示字号;
2、捕获超级终端操作命令行,以备日后查对;
3、 language-mode Chinese|English 中英文切换 ;
4、复制命令到超级终端命令行, 粘贴到主机;
5、交换机清除配置 :reset save ;reboot ;
6、路由器、交换机配置时不能掉电,连通测试前一定要
检查网络的连通性,不要犯最低级的错误。
7、192.168.1.1/24 等同 192.168.1.1 255.255.255.0;在配置交换机和路
由器时, 192.168.1.1 255.255.255.0 可以写成: 192.168.1.1 24
8、设备命名规则:地名-设备名-系列号 例:PingGu-R-S3600

华为交换机中小企业或大企分支机构的常用配置
在中小企业或大企业的分支机构中,二层以太网交换机作为二层汇聚交换机,可以
直接接用户,上行连接到二/三层以太网交换机,可以通过路由器连接到总部或其
它分支机构的网络。
在组网中将每个部门划分在一个VLAN中;为了便于网管,需要配置SNMP;为了防止
交换机被非法访问,交换机上需要配置对访问方式的ACL控制。
整个网络采用VLAN10作为管理VLAN,所有交换机上VLAN10接口的IP地址在同一个网
段10.110.110.0/24,主RADIUS服务器的IP为10.110.10.18;网管工作站的IP地址
为10.11.10.1。路由器的IP地址为10.100.11.1,二/三层交换机通过 VLAN2接口与
路由器

相连,VLAN2接口的IP地址为10.100.11.2。
在二层交换机上作如下配置:管理VLAN配置、网管路由配置、SNMP配置、各种访问
方式的ACL控制配置;hybrid端口配置。
在二/三层交换机上进行如下配置:网关配置、hybrid端口配置、SNMP配置、各种
访问方式的ACL控制配置、各个部门间的相互访问的控制。
本文仅说明交换机上的基本配置。
1. 配tch B
下面以网络中某部门tch B为例说明基本配置过程。此部门所有的计算机配置在一
个VLAN内。
(1) 配置VLAN。
[Quidway] vlan 5
[Quidway-vlan5]port ethernet 0/1 to Ethernet 0/24 ethernet 1/1
[Quidway-vlan5] quit
(2) 配置管理VLAN及路由。
# 管理VLAN为VLAN 10。
[Quidway] interface vlan 10
[Quidway-Vlan-interface10]ip address 10.110.110.2 255.255.255.0
# 配置路由,下一跳为10.110.110.1。
[Quidway] ip route 10.11.10.1 255.255.255.248 10.110.110.1
(3) 配置上行端口Ethernet1/1为hybrid端口,允许VLAN10和VLAN5的报文通过。
[Quidway] interface Ethernet1/1
[Quidway-Ethernet1/1] port link-type hybrid
[Quidway-Ethernet1/1] port hybrid pvid vlan 5
[Quidway-Ethernet1/1] port hybrid vlan 10 tagged
(4) 配置SNMP
# 进入全局配置模式。
system-view
# 设置团体名和访问权限。
[Quidway] snmp-agent community read huawei
[Quidway] snmp-agent community write beiyan
# 设置管理员标识、联系方法以及以太网交换机的物理位置。
[Quidway] snmp-agent sys-info contact Mr.Wang-Tel:3306
[Quidway] snmp-agent sys-info location telephone-closet,3rd-floor
# 允许发送Trap。
[Quidway] snmp-agent trap enable
# 定义访问控制列表,以便进行对通过SNMP访问交换机的用户进行ACL控制。
[Quidway] acl number 1
[Quidway-acl-basic-1] rule 0 permit source 10.11.10.1 0
# 创建SNMP组,并定义访问控制。
[Quidway] snmp-agent group v3 huaweigroup acl 1
# 为SNMP组添加一个用户huaweimanager,设置认证密码为hello,并配置访问控
制,只允许网管工作站访问交换机。
[Quidway]snmp-agent usm-user v3 huaweimanager huaweigroup auth md5
huawei acl 1
(5) 配置对TELNET用户的访问控制,仅允许IP为10.110.110.46和10.110.110.52的
用户通过TELNET访问交换机。
# 定义基本访问控制列表。
[Quidway] acl number 20
[Quidway-acl-basic-20] rule 0 permit source 10.110.110.46 0
[Quidway-acl-basic-20] rule 1 permit source 10.110.110.52 0
# 引用访问控制列表。
[Quidway] user-interface vty 0 4
[Quidway-ui-vty0-4] acl 20 inbound
(6) 配置对HTTP用户的访问控制,仅允许IP地址为10.110.110.46的主机通过WEB方
式访问交换机。
# 定义基本访问控制列表。
[Quidway] acl number 30
[Quidway-acl-basic-30] rule 0 permit source 10.110.110.46 0
# 引用访问控制列表。
[Quidway]ip http acl 30







# 进入系统视图。

system-view

# 创建VLAN 10,并指定VLAN 10为交换机的管理VLA

N。

[SwitchA] vlan 10

[SwitchA-vlan10] quit

[SwitchA] management-vlan 10

# 创建交换机管理VLAN 10的VLAN接口并进入VLAN接口视图。

[SwitchA] interface vlan-interface 10

# 配置管理VLAN 10接口的IP地址为1.1.1.1/24。

[SwitchA-Vlan-interface10] ip address 1.1.1.1 255.255.255.0

[SwitchA-Vlan-interface10] quit

# 配置缺省路由。

[SwitchA] ip route-static 0.0.0.0 0.0.0.0 1.1.1.2

下载文档原格式(Txt原格式,共3页)
相关文档
  • h3c交换机常用命令

  • 交换机常用命令

  • 光纤交换机常用命令

  • 交换机配置常用命令

  • h3c交换机配置命令

  • h3c常用命令