搜档网
当前位置:搜档网 > H3C华为交换机配置基本命令

H3C华为交换机配置基本命令

H3C交换机路由器常用命令

local-user admin (建立TELNET 用户)

password simple admin

authorization-attribute level 3

service-type telnet

stp enable (开启生成树功能)

interface Vlan-interface1 ip address 1.1.1.1 255.255.255.0(为只定VLAN配置IP地址)port access vlan 20 (在端口模式下将接口添加到相关VLAN)

(接口的TRUNK配置)

port link-type trunk

port trunk permit vlan all

user-interface vty 0 4

authentication-mode scheme(开启TELNET 服务的虚拟端口)

user-interface vty 5 15

description

首先配置交换机的管理IP地址

[H3C]interface Vlan-interface 1

[H3C-vlan-interface1]ip address 10.0.0.1 255.255.255.0

只用密码的用户认证

[H3C]user-interface vty 0 4

[H3C-ui-vty0-4]authentication-mode password

[H3C-ui-vty0-4]set authentication password simple 123456

远程用户缺省的级别都是0级,Telnet用户登录后的用户级别

[H3C-ui-vty0-4]user privilege level 3

本地用户名和口令的认证

[H3C]user-interface vty 0 4

[H3C-ui-vty0-4]authentication-mode scheme

[H3C]local-user H3C

[H3C-ui-vty0-4]password simple huawei

[H3C-ui-vty0-4]service-type telnet level 3

1.调整超级终端的显示字号;

2.捕获超级终端操作命令行,以备日后查对;

3.复制命令到超级终端命令行,粘贴到主机;

4.路由器.交换机配置时不能掉电,连通测试前一定要检查网络的连通性,不要犯最低级的错误。5.在IP地址写法上:192.168.1.1/24等同192.168.1.1 255.255.255.0;

在配置交换机和路由器时,192.168.1.1 255.255.255.0 可以写成:192.168.1.1 24

6.设备命名规则:地名-设备名-系列号例:PingGu-Router-S3600

H3C交换机

1.system-view 进入系统视图模式

2.sysname 为设备命名

3.display current-configuration 当前配置情况

4.language-mode Chinese|English 中英文切换

5.interface Ethernet 1/0/1 进入以太网端口视图

6.port link-type Access|Trunk|Hybrid 设置端口访问模式

7.undo shutdown 打开以太网端口

8.shutdown 关闭以太网端口

9.quit 退出当前视图模式

10.vlan 10 创建VLAN 10并进入VLAN 10的视图模式

11.port access vlan 10 在端口模式下将当前端口加入到vlan 10中

12.port E1/0/2 to E1/0/5 在VLAN模式下将指定端口加入到当前vlan中

13.port trunk permit vlan all 允许所有的vlan通过

14.交换机清除配置 :reset save ;reboot

15.192.168.1.1/24等同192.168.1.1 255.255.255.0;在配置交换机和路由器时,192.168.1.1 255.255.255.0 可以写成:192.168.1.1 24

H3C路由器

1.system-view 进入系统视图模式

2.sysname R1 为设备命名为R1

3.display ip routing-table 显示当前路由表

4.language-mode Chinese|English 中英文切换

5.interface Ethernet 0/0 进入以太网端口视图

6.ip address 192.168.1.1 255.255.255.0 配置IP地址和子网掩码

7.undo shutdown 打开以太网端口

8.shutdown 关闭以太网端口

9.quit 退出当前视图模式

10.ip route-static 192.168.2.0 255.255.255.0 192.168.12.2 description To.R2 配置静态路由11.ip route-static 0.0.0.0 0.0.0.0 192.168.12.2 description To.R2 配置默认的路由

端口表示方法E1/0/1

显示系统版本信息:display version

显示诊断信息:display diagnostic-information

显示系统当前配置:display current-configuration

显示系统保存配置: display saved-configuration

显示接口信息:display interface

显示路由信息:display ip routing-table

显示VLAN信息:display vlan

显示生成树信息:display stp

显示MAC地址表:display mac-address

显示ARP表信息:display arp

显示系统CPU使用率:display cpu

显示系统内存使用率:display memory

显示系统日志:display log

显示系统时钟:display clock

验证配置正确后,使用保存配置命令:save

删除某条命令,一般使用命令: undo

一、Console口登录方式:最简单的配置认证方式为none(默认)

# 进入系统视图。

system-view

# 进入AUX用户界面视图。

[H3C] user-interface aux 0

# 配置通过AUX用户界面登录交换机的用户不需要进行认证。

[H3C-ui-aux0] authentication-mode none

# 配置通过AUX用户界面登录后可以访问的命令级别为2级。

[H3C-ui-aux0] user privilege level 2

# 配置AUX用户界面使用的波特率为9600bit/s。

[H3C-ui-aux0] speed 9600

# 配置AUX用户界面终端屏幕的一屏显示30行命令。

[H3C-ui-aux0] screen-length 30

# 配置AUX用户界面的历史命令缓冲区可存放20条命令。

[H3C-ui-aux0] history-command max-size 20

# 配置AUX用户界面的超时时间为6分钟。

[H3C-ui-aux0] idle-timeout 6

完成上述配置后,用户需要改变PC机上运行的终端仿真程序的相应配置,使之与交换机上的配置保持一致,才能确保正常登录。

二、Console口登录方式:配置进入口令,认证方式为Password

# 进入系统视图。

system-view

# 进入AUX用户界面视图。

[H3C] user-interface aux 0

# 配置通过AUX用户界面登录交换机的用户进行Password认证。

[H3C-ui-aux0] authentication-mode password

# 配置用户的认证口令为明文显示方式,口令为123456。

[H3C-ui-aux0] set authentication password simple 123456

# 配置通过AUX用户界面登录后可以访问的命令级别为2级。

[H3C-ui-aux0] user privilege level 2

# 配置AUX用户界面使用的波特率为9600bit/s。

[H3C-ui-aux0] speed 9600/s

# 配置AUX用户界面终端屏幕的一屏显示30行命令。

[H3C-ui-aux0] screen-length 30

# 配置AUX用户界面的历史命令缓冲区可存放20条命令。

[H3C-ui-aux0] history-command max-size 20

# 配置AUX用户界面的超时时间为6分钟。

[H3C-ui-aux0] idle-timeout 6

完成上述配置后,用户需要改变PC机上运行的终端仿真程序的相应配置,使之与交换机上的配置保持一致,才能确保正常登录。

三、Console口登录方式:配置用户和口令,认证方式为scheme

# 进入系统视图。

system-view

# 创建本地用户guest,并进入本地用户视图。

[H3C] local-user guest

# 配置本地用户的认证口令为明文显示方式,口令为123456。

[H3C-luser-guest] password simple 123456

# 配置本地用户的服务类型为Terminal且命令级别为2级。

[H3C-luser-guest] service-type terminal level 2

[H3C-luser-guest] quit

# 进入AUX用户界面视图。

[H3C] user-interface aux 0

# 配置通过AUX用户界面登录交换机的用户进行Scheme认证。

[H3C-ui-aux0] authentication-mode scheme

# 配置AUX用户界面使用的波特率为9600bit/s。

[H3C-ui-aux0] speed 9600

# 配置AUX用户界面终端屏幕的一屏显示30行命令。

[H3C-ui-aux0] screen-length 30

# 配置AUX用户界面的历史命令缓冲区可存放20条命令。

[H3C-ui-aux0] history-command max-size 20

# 配置AUX用户界面的超时时间为6分钟。

[H3C-ui-aux0] idle-timeout 6

完成上述配置后,用户需要改变PC机上运行的终端仿真程序的相应配置,使之与交换机上的配置保持一致,才能确保正常登录。

[H3C]sysname LIANXI

#################交换机命名

[PG.LIANXI]super password cipher lianxi

#################设置用户窗口进入系统窗口密码为lianxi

[PG.LIANXI]user-interface vty 0 4

#################进入TELNET虚接口,0 4说明同时可以允许最多五个用户

[PG.LIANXI -vty0-4]authentication-mode password

#################设置TELNET密码访问模式

[PG.LIANXI -vty0-4]set authentication password simple lianxi

#################设置TELNET访问密码为lianxi

[PG.LIANXI -vty0-4]user privilege level 3

#################telnet访问级别为3级

[PG.LIANXI -vty0-4]quit

[PG.LIANXI]

[PG.LIANXI]vlan 2

[PG.LIANXI-vlan2]port Ethernet 1/0/1

[PG.LIANXI-vlan2]description UpLink.To.H3C S5600

[PG.LIANXI]

[PG.LIANXI]interface vlan-interface 2

[PG.LIANXI-Vlan-interface2]ip address 211.153.10.154 255.255.255.248

[PG.LIANXI-Vlan-interface2]quit

[PG.LIANXI]

[PG.LIANXI]ip route-static 0.0.0.0 0.0.0.0 211.153.10.153 preference 60

[PG.LIANXI]

[PG.LIANXI]interface Ethernet 1/0/19

[PG.LIANXI-Ethernet1/0/16]port link-type trunk

[PG.LIANXI-Ethernet1/0/16]port trunk permit vlan 601 to 622

[PG.LIANXI-Ethernet1/0/16]quit

[PG.LIANXI]

H3C交换机、路由器Console和Telnet密码配置

一、H3C 交换机密码配置

H3C华为交换机配置基本命令

(一)CONSOLE口登陆

在AUX用户接口视图下,可以设置CONSOLE用户登陆的口令认证。有如下三种认证方式None:不需要口令认证

Password:需要简单的本地口令认证,包含明文(simple)和密文(cipher)

Scheme:通过RADIUS服务器或本地提供用户名和认证口令

配置命令如下:

system-view

[H3C]user-interface aux 0

[H3C-ui-aux0]authentication-mode password

[H3C-ui-aux0]set authenticaton password simple 123456

推出重新登陆,交换机提示用户输入访问口令

Login authentication Password:

用户的命令控制级别设置

[H3C-ui-aux0]user privilege level 0

[H3C]super password level 1 simple 123456

[H3C]super password level 2 simple 123456

[H3C]super password level 3 simple 123456

(二)Telnet 配置

首先配置交换机的管理IP地址

[H3C]interface Vlan-interface 1

[H3C-vlan-interface1]ip address 10.0.0.1 255.255.255.0

只用密码的用户认证

[H3C]user-interface vty 0 4

[H3C-ui-vty0-4]authentication-mode password

[H3C-ui-vty0-4]set authentication password simple 123456

远程用户缺省的级别都是0级,Telnet用户登录后的用户级别

[H3C-ui-vty0-4]user privilege level 3

本地用户名和口令的认证

[H3C]user-interface vty 0 4

[H3C-ui-vty0-4]authentication-mode scheme

[H3C]local-user H3C

[H3C-ui-vty0-4]password simple huawei

[H3C-ui-vty0-4]service-type telnet level 3

二、H3C路由器配置Console口和Telnet

CONSOLE和TELNET一样的,只要配置了会同时启作用,且只能是用户名和密码的方式。[Quidway]local-user quidway service-type administrator password simple h3c CONSOLE:

通过密码:

[Quidway]user-interface con 0

[Quidway-ui-console0]authentication-mode password

[Quidway-ui-console0]set authentication password simple h3c

[Quidway-ui-console0]user privilege level 3------------->可以不配置,默认级别是3 通过用户名和密码:

[Quidway]user-interface con 0

[Quidway-ui-console0]authentication-mode local

[Quidway]local-user quidway password simple h3c

[Quidway]local-user quidway service-type terminal

[Quidway]local-user quidway level 3

TELNET:

通过密码:

[Quidway]user-interface vty 0 4

[Quidway-ui-vty0-4] authentication-mode password

[Quidway-ui-vty0-4] set authentication password simple h3c

[Quidway-ui-vty0-4] user privilege level 3

通过用户名和密码:

[Quidway]user-interface vty 0 4

[Quidway-ui-vty0-4]authentication-mode local

[Quidway]local-user quidway password simple h3c

[Quidway]local-user quidway service-type telnet

[Quidway]local-user quidway level 3

VRP3.4

CONSOLE:

通过密码:

[Quidway]user-interface con 0

[Quidway-ui-console0]authentication-mode password

[Quidway-ui-console0]set authentication password simple h3c

[Quidway-ui-console0]user privilege level 3------------->可以不配置,默认级别是3 通过用户名和密码:

[Quidway]local-user quidway

[Quidway-luser-quidway]password simple h3c

[Quidway-luser-quidway]service-type terminal level 3

[Quidway]user-interface con 0

[Quidway-ui-console0]authentication-mode scheme

TELNET:

通过密码:

[Quidway]user-interface vty 0 4

[Quidway-ui-vty0-4]authentication-mode password

[Quidway-ui-vty0-4]set authentication password simple h3c

[Quidway-ui-vty0-4]user privilege level 3

通过用户名和密码:

[Quidway]user-interface vty 0 4

[Quidway-ui-vty0-4]authentication-mode password

[Quidway-ui-vty0-4]set authentication password simple h3c

[Quidway]local-user quidway

[Quidway-luser-quidway]password simple h3c

[Quidway-luser-quidway]service-type telnet level 3

通过用户名和密码:

[Quidway]user-interface vty 0 4

[Quidway-ui-vty0-4]authentication-mode scheme

[Quidway]local-user quidway

[Quidway-luser-quidway]password simple h3c

[Quidway-luser-quidway]service-type telnet level 1

[Quidway]super password level 3 simple h3cpass

MSR系列路由器Console登陆认证功能的配置

一、组网需求:

要求用户从console登录时输入已配置的用户名huawei3com和对应的口令huawei3com,用户名和口令正确才能登录成功。

二、组网图:

H3C华为交换机配置基本命令

三、配置步骤:

//创建本地帐号与密码

local-user huawei3com

password simple huawei3com

//设置服务类型为terminal

service-type terminal

//设置用户优先级为3

level 3

#

//设置scheme认证

user-interface con 0

authentication-mode scheme

#

四、配置关键点:

1) 在配置完成后,需保存配置重新启动设备后生效。

display history-command

【命令】display history-command

【视图】任意视图

【参数】无

【描述】

display history-command 命令用来显示当前用户最近执行过的有效历史命令,以便用户查看之前的配置。这些历史命令存放在历史命令缓冲区,历史命令缓冲区的大小可以通过history-command max-size 命令来设置。历史命令缓冲区充满时,旧的信息会被覆盖。缺省情况下,命令行接口为每个用户保存10 条有

效历史命令。相关配置可参考“登录交换机”中的命令history-command max-size。

【举例】

# 显示当前用户使用过的有效历史命令。

display history-command

system-view

quit

display history-command

super password

【命令】

super password [ level level ] { cipher | simple } password

undo super password [ level level ]

【视图】系统视图

【参数】level level:用户的级别,取值范围为1~3。缺省值为3,即如果不指定具体的级别,表示设置的是进入级别3 的口令。

cipher:在配置文件中以密文方式显示口令。

simple:在配置文件中以明文方式显示口令。

H3C S2126-EI 以太网交换机命令手册,命令行接口第1 章命令行接口命令1-5

password:口令字符串。如果验证方式是simple,则password 必须是明文口令,取值范围为1~16 个字符的字符串;如果验证方式是cipher,则用户在设置password 时有两种方式:

一种是输入小于等于16字符的明文口令,系统会自动转化为24位的密文形式;

另一种是直接输入24 字符的密文口令,此时用户必须知道其对应的明文形式。

如:密文“_(TT8F]Y\5SQ=^Q`MAF4<1!!”对应的明文是“1234567”。

【描述】

super password 命令用来设置切换低级别用户到高级别用户的口令。undo super

password 命令用来恢复缺省情况。

缺省情况下,没有设置切换低级别用户到高级别用户的口令。

需要注意的是,不论配置的是明文口令还是密文口令,验证时必须输入明文形式的口令。

【举例】

# 配置从低级别切换到级别3 的口令为“0123456789”,显示方式为明文显示。

system-view

System View: return to User View with Ctrl+Z.

[H3C] super password level 3 simple 0123456789

lock

【命令】lock

【视图】用户视图

【参数】无

【描述】

lock 命令用来锁住当前用户界面,防止未授权的用户操作该界面。用户输入lock 命令后,系统提示输入密码,并提示再次输入密码,只有两次输入的密码相同,锁定操作才能成功。如果用户需要结束锁定,请按<回车>键,然后按照提示输入刚才配置的密码,密码正确则结束锁定,进入系统。需要注意的是:如果用户设定的密码长度超过16 个字符,系统在取消锁定时只匹配前16 个字符。即,只要密码的前16 个字符正确,系统就取消锁定。缺省情况下,不会自动锁定当前用户界面。

【举例】# 锁住当前用户界面。

lock 回车后,系统提示输入及确认密码,输入的密码为隐藏状态。

Password:

Again:

locked !

此时用户界面处于锁定状态,再对界面进行操作,系统会提示用户输入密码,输入正确的密码后,才能进入用户视图。

set authentication password

【命令】set authentication password { cipher | simple } password

undo set authentication password

【视图】用户界面视图

【参数】

cipher:设置本地认证口令以密文方式存储。

simple:设置本地认证口令以明文方式存储

password:口令字符串。如果验证方式是simple,则password 必须是明文口令。如果验证方式是cipher,则用户在设置password 时有两种方式:一种是输入小于等于16字符的明文口令,系统会自动转化为24位的密文形式;另一种是直接输入24字符的密文口令,此时用户必须知道其对应的明文形式。如:明文“123456”对应的密文是“OUM!K%F<+$[Q=^Q`MAF4<1!!”。

【描述】set authentication password 命令用来设置本地认证的口令。undo set

authentication password 命令用来取消本地认证的口令。需要注意的是,不论配置的是明文口令还是密文口令,验证时必须输入明文形式的口令。说明:用户通过Modem 或Telnet 方式登录时,缺省情况下需要进行口令认证。如果没有配置口令,则终端屏幕将显示“Login password has not been set !”,并断开与交换机的连接。

【举例】

# 设置VTY0 的本地认证明文口令为123。

system-view

System View: return to User View with Ctrl+Z.

[H3C] user-interface vty 0

[H3C-ui-vty0] set authentication password simple 123

telnet

【命令】telnet { hostname | ip-address } [ service-port ]

【视图】用户视图

【参数】

hostname:远端设备的主机名,为1~20 个字符的字符串。

ip-address:远端设备的IP 地址。

service-port:远端设备提供Telnet 服务的TCP 端口号,取值范围为0~65535。

【描述】telnet 命令用来使用户可以方便地从当前以太网交换机登录到其它以太网交换机进行远程管理。用户可以使用组合键或quit 命令来中断本次Telnet 登录。缺省情况下,Telnet 服务的端口号为23。

【举例】

# 从当前以太网交换机H3C1登录到另外一台以太网交换机H3C2(IP地址为

129.102.0.1)。

telnet 129.102.0.1

Trying 129.102.0.1 ...

Press CTRL+K to abort

Connected to 129.102.0.1 ...

********************************************************************

Copyright (c) 2004-2007 Hangzhou H3C Tech. Co., Ltd. All rights reserved.*

* Without the owner's prior written consent, *

* no decompiling or reverse-engineering shall be allowed. *

*******************************************************************

user privilege level

【命令】user privilege level level

undo user privilege level

【视图】用户界面视图

【参数】level:从用户界面登录后可以访问的命令级别,取值范围为0~3。

【描述】

user privilege level 命令用来设置从某用户界面登录后可以访问的命令级别。Undo user privilege level 命令用来恢复缺省情况。缺省情况下,从AUX 用户界面登录后可以访问的命令级别为3 级,从VTY 用户界面登录后可以访问的命令级别为0 级。命令级别共分为访问、监控、系统、管理4 个级别,分别对应标识0、1、2、3,简介如下:

访问级(0 级):用于网络诊断等功能的命令。包括ping、tracert、telnet等命令,执行该级别命令的结果不能被保存到配置文件中。

监控级(1 级):用于系统维护、业务故障诊断等功能的命令。包括debugging、terminal 等命令,执行该级别命令的结果不能被保存到配置文件中。

系统级(2 级):用于业务配置的命令。包括路由等网络层次的命令,用于向用户提供网络服务。

管理级(3 级):关系到系统的基本运行、系统支撑模块功能的命令,这些命令对业务提供支撑作用。包括文件系统、FTP、TFTP、XModem 下载、用户管理命令、级别设置命令等。

有关命令级别的详细信息,请参见“命令行接口”部分。

【举例】

# 设置从VTY0 用户界面登录后可以访问的命令级别为1。

system-view

System View: return to User View with Ctrl+Z.

[H3C] user-interface vty 0

[H3C-ui-vty0] user privilege level 1

# 通过Telnet 方式从VTY0 用户界面登录交换机后,可以看到终端上只显示了命令级别为1 级的命令。 ?

User view commands:

cluster Run cluster command

debugging Enable system debugging functions

display Display current system information

msdp-tracert MSDP trace route to source RP

mtracert Trace route to multicast source

nslookup Query Internet name servers

ping Ping function

quit Exit from current command view

reset Reset operation

send Send information to other user terminal interfaces

super Set the current user priority level

telnet Establish one TELNET connection

terminal Set the terminal line characteristics

tracert Trace route function

undo Cancel current setting

display current-configuration

【命令】display current-configuration [ configuration [ configuration-type ] | interface[ interface-type ] [ interface-number ] ] [ by-linenum ] [ | { begin | include | exclude } regular-expression ]

【视图】任意视图

【参数】configuration configuration-type:显示非接口配置。如果不指定configuration-type,则显示所有的非接口配置;如果指定configuration-type,则显示指定功能的配置。configuration-type 的取值与用户当前已配置的功能有关,例如:

isp:表示网络服务提供商的配置。

radius-template:表示RADIUS 模板类型的配置。

system:表示系统配置。

user-interface:表示用户界面的配置。

interface interface-type interface-number:显示接口的配置。interface-type 为接口

类型,可以是Aux、Ethernet、LoopBack、NULL、Vlan-interface。

interface-number 为接口编号。

by-linenum:以带有行编号的形式显示配置信息。

|:使用正则表达式过滤显示的配置。

begin:显示以指定文字(regular-expression)开始的配置及之后的所有配置。

include:显示包含指定文字(regular-expression)的配置。

exclude:显示不含指定文字(regular-expression)的配置。

【描述】

display current-configuration 命令用来显示设备当前的配置。

当用户完成一组配置之后,需要验证配置是否生效,则可以执行display

current-configuration 命令来查看当前生效的参数。

需要注意的是:

如果当前配置的参数与缺省参数相同,则不予显示。

对于某些参数,虽然用户已经配置,但如果这些参数对应的功能没有生效,则不予显示。

相关配置可参考命令save , reset saved-configuration , display

saved-configuration。

【举例】

# 显示以太网交换机当前的接口的配置信息。

display current-configuration interface

display current-configuration vlan

【命令】display current-configuration vlan [ vlan-id ] [ by-linenum ]

【视图】任意视图

H3C S2126-EI 以太网交换机命令手册

配置文件管理第1 章配置文件管理命令1-6

【参数】vlan vlan-id:VLAN 编号,取值范围为1~4094。

by-linenum:以带有行编号的形式显示配置信息。

【描述】display current-configuration vlan 命令用来显示交换机当前VLAN 的配置信息。如果不指定vlan-id 参数,则显示交换机当前所有VLAN 的配置信息。需要注意的是,如果存在连续编号的VLAN 且这些VLAN 无任何配置,在显示配置信息时将连续的空配置VLAN 合并。

相关配置可参考命令save , reset saved-configuration , display

saved-configuration。

【举例】

# 显示以太网交换机中当前VLAN 的配置信息。

display current-configuration vlan

#

vlan 1

#

vlan 100 to 200

#

return

display vlan

【命令】display vlan [ vlan-id [ to vlan-id ]|all | dynamic|static ]

【视图】任意视图

【参数】vlan-id:指定VLAN ID,取值范围为1~4094。

to:指定多个连续的VLAN ID,to 之后的VLAN 编号不能小于to 之前的。

all:显示所有VLAN 的相关信息。

dynamic:显示动态VLAN(指通过GVRP 协议注册的VLAN)信息。

static:显示静态VLAN(指通过手工配置创建的VLAN)信息。

【描述】

display vlan 命令用来显示VLAN 的相关信息。

如果使用参数vlan-id,则显示指定VLAN 的相关信息。

如果不使用参数vlan-id,则显示系统已存在的VLAN 的编号。

如果选用dynamic或static参数,则显示系统已存在的动态或静态VLAN 数量及VLAN 编号。相关配置可参考命令vlan。

【举例】

# 显示VLAN1 的信息。

display vlan 1

VLAN ID: 1

VLAN Type: static

Route Interface:

idle-timeout

【命令】idle-timeout minutes [ seconds ]

undo idle-timeout

【视图】用户界面视图

【参数】minutes:分钟数,取值范围为0~35791。seconds:秒数,取值范围为0~59。

【描述】idle-timeout 命令用来配置用户超时断开连接的时间,如果在所设定的时间内登录到当前用户界面上的用户没有对交换机执行任何操作,则交换机将断开与该用户的连接。undo idle-timeout 命令用来恢复超时断开连接的缺省值。缺省情况下,用户超时断开连接的时间为10 分钟。设置idle-timeout 0 即关闭超时中断连接功能。

【举例】

# 设置AUX0 用户界面的超时断开连接时间为1 分钟。

system-view

System View: return to User View with Ctrl+Z.

[H3C] user-interface aux 0

[H3C-ui-aux0] idle-timeout 1

name

【命令】name text

undo name

【视图】VLAN 视图

【参数】

text:VLAN 名称,为1~32 个字符的字符串(可以包含特殊字符及空格)。

【描述】name 命令用来指定当前VLAN 的名称。undo name 命令用来恢复当前VLAN 名称的缺省值。缺省情况下,VLAN 的名称为该VLAN 的VLAN ID,如“VLAN 0001”。

【举例】

# 指定VLAN 2 的名称为“test vlan”。

system-view

System View: return to User View with Ctrl+Z.

[H3C] vlan 2

[H3C-vlan2] name test vlan

port

【命令】port interface-list undo port interface-list

【视图】VLAN 视图

【参数】interface-list:需要添加到某个VLAN 中或从某个VLAN 中删除的以太网端口列表,表示方式为interface-list={ interface-type interface-number [ to interface-typeinterface-number ] } &<1-10>。其中interface-type 为端口类型,interface-number为端口号。关键字to 之后的端口号要大于或等于to 之前的端口号。命令中&<1-10>表示前面的参数最多可以输入10 次。

【描述】port 命令用来向VLAN 中添加一个或一组端口。undo port 命令用来从VLAN 中删除一个或一组端口。

注意:

以上命令只对Access 端口有效。将Trunk 端口和Hybrid 端口加入VLAN,只能通过以太网端口视图下的port trunk permit vlan 和port hybrid vlan 命令实现,相关命令的描述请参见本手册“端口基本配置”部分的介绍。相关配置可参考命令display vlan。

【举例】

# 向VLAN 2 中加入从Ethernet1/0/2 到Ethernet1/0/4 的以太网端口。

system-view

System View: return to User View with Ctrl+Z.

[H3C] vlan 2

[H3C-vlan2] port Ethernet 1/0/2 to Ethernet 1/0/4

ip address

【命令】

ip address ip-address { mask | mask-length }

undo ip address [ ip-address { mask | mask-length } ]

【视图】VLAN 接口视图/LoopBack 接口视图

【参数】ip-address:IP 地址,点分十进制格式。

mask:子网掩码,点分十进制格式。

mask-length:子网掩码长度,取值范围为0~32。

【描述】

ip address 命令用来配置VLAN 接口/LoopBack 接口的IP 地址和掩码。undo ip address 命令用来删除VLAN 接口/LoopBack 接口的IP 地址和掩码。缺省情况下,没有为VLAN 接口/LoopBack 接口配置IP 地址。

说明:

新配置的IP 地址将覆盖原有的IP 地址。同一设备上VLAN 接口和LoopBack接口的IP 地址不能在同一网段。相关配置可参考命令display ip interface。

【举例】

# 配置VLAN 接口1 的IP 地址为129.12.0.1,子网掩码为255.255.255.0。

system-view

System View: return to User View with Ctrl+Z.

[H3C] interface Vlan-interface 1

[H3C-Vlan-interface1] ip address 129.12.0.1 255.255.255.0

配console

user-interface aux 0

authentication-mode scheme/password

local-user 用户名

password cipher 密码

service-type telnet terminal level 3

q

配Telnet

user-interface vty 0 4

authentication-mode scheme【方案】

save

恢复出厂配置

reset saved-configuration

reboot

出厂配置没有用户名和密码,恢复出厂设置后设置的用户名和密码依然存在;

12、配置生成树(预防环路发生)

stp enable

端口绑定配置举例

# 进入系统视图。

system-view

# 进入GigabitEthernet1/0/1端口视图。

[H3C] interface GigabitEthernet1/0/1

# 将PC1的MAC地址和IP地址绑定到GigabitEthernet1/0/1端口。

[H3C-GigabitEthernet1/0/1] am user-bind mac-addr 00-1E-90-7F-C6-C0 ip-addr 10.12.1.1

[Quidway]super password 修改特权用户密码

[Quidway]sysname 交换机命名

[Quidway]interface ethernet 0/1 进入接口视图

[Quidway]interface vlan x 进入接口视图

[Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0

[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2 静态路由=网关

[Quidway]user-interface vty 0 4

[S3026-ui-vty0-4]authentication-mode password

[S3026-ui-vty0-4]set authentication-mode password simple 222

[S3026-ui-vty0-4]user privilege level 3

[Quidway-Ethernet0/1]duplex {half|full|auto} 配置端口双工工作状态

[Quidway-Ethernet0/1]speed {10|100|auto} 配置端口工作速率

[Quidway-Ethernet0/1]flow-control 配置端口流控

[Quidway-Ethernet0/1]mdi {across|auto|normal} 配置端口MDI/MDIX状态平接或扭接[Quidway-Ethernet0/1]port link-type {trunk|access|hybrid} 设置接口工作模式

[Quidway-Ethernet0/1]shutdown 关闭/重起接口

[Quidway-Ethernet0/2]quit 退出系统视图

Command-privilege level 3

# 配置进入用户视图的欢迎信息。

header login %Welcome to login!%

# 创建并指定 VLAN 10为管理 VLAN,并进入 Vlan-interface10的接口视图。

system-view

System View: return to User View with Ctrl+Z.

[Sysname] vlan 10

[Sysname-vlan10] quit

[Sysname] management-vlan 10

[Sysname] interface Vlan-interface 10

[Sysname-Vlan-interface10]

# 为当前管理 VLAN 1的接口配置 IP地址为 192.168.0.51,掩码 255.255.255.0。

system-view

System View: return to User View with Ctrl+Z.

[Sysname] interface Vlan-interface 1

[Sysname-Vlan-interface1] ip address 192.168.0.51 255.255.255.0

# 配置缺省路由的下一跳为 129.102.0.2。

system-view

System View: return to User View with Ctrl+Z.

[Sysname] ip route-static 0.0.0.0 0.0.0.0 129.102.0.2

# 设置管理 VLAN为 VLAN 2。

system-view

System View: return to User View

[Sysname] management-vlan 2

# 配置 VLAN接口 1的 IP地址为 129.12.0.1,子网掩码为 255.255.255.0。 system-view

System View: return to User View with Ctrl+Z.

[Sysname] interface Vlan-interface 1

[Sysname-Vlan-interface1] ip address 129.12.0.1 255.255.255.0

下载文档原格式(Word原格式,共16页)
相关文档
  • 华为交换机配置命令

  • 华为交换机基本命令

  • h3c交换机配置命令

  • 华为交换机常用命令

  • h3c交换机常用命令

  • 华为交换机常见命令