搜档网
当前位置:搜档网 > H3C交换机最详细配置实例手册

H3C交换机最详细配置实例手册

H3C 交换机最详细配置实例手册

资料整理:hupoboy

目录

1.登录交换机典型配置指导 (7)

1.1 通过Console 口配置Telnet 登录方式典型配置指导 (7)

1.1.1 组网图 (7)

1.1.2 应用要求 (7)

1.1.3 配置过程和解释 (7)

1.1.4 完整配置 (8)

1.2 通过Telnet 配置Console 口登录方式典型配置指导 (9)

1.2.1 组网图 (9)

1.2.2 应用要求 (9)

1.2.3 配置过程和解释 (9)

1.2.4 完整配置 (10)

1.3 通过WEB 网管登录交换机典型配置指导 (11)

1.3.1 组网图 (11)

1.3.2 应用要求 (11)

1.3.4 配置过程和解释 (11)

1.3.5 完整配置 (12)

1.3.6 配置注意事项 (12)

1.4 对登录用户的控制典型配置指导 (12)

1.4.1 组网图 (12)

1.4.2 应用要求 (12)

1.4.3 配置过程和解释 (12)

1.4.4 完整配置 (13)

2. VLAN 典型配置指导 (14)

2.1 基于端口的VLAN 典型配置指导 (14)

2.1.1 组网图 (14)

2.1.2 应用要求 (14)

2.1.3 配置过程和解释 (14)

2.1.4 完整配置 (15)

2.2 基于MAC 的VLAN 典型配置指导 (16)

2.2.1 组网图 (16)

2.2.2 应用要求 (16)

2.2.3 配置过程和解释 (16)

2.2.4 完整配置 (17)

2.2.5 配置注意事项 (18)

2.3 基于协议的VLAN 典型配置指导 (18)

2.3.1 组网图 (18)

2.3.2 应用要求 (19)

2.3.3 配置过程和解释 (19)

2.3.4 完整配置 (19)

2.4 基于IP 子网的VLAN 典型配置指导 (20)

2.4.1 组网图 (20)

2.4.2 应用要求 (20)

2.4.3 配置过程和解释 (21)

2.4.5 完整配置 (21)

2.5 Isolate-user-vlan 典型配置指导 (22)

2.5.1 组网图 (22)

2.5.2 应用要求 (22)

2.5.3 配置过程和解释 (22)

2.5.6 完整配置 (23)

3. IPv4 ACL 典型配置指导 (25)

3.1 基本IPv4 ACL 典型配置指导 (25)

3.1.1 组网图 (25)

3.1.2 应用要求 (25)

3.1.3 配置过程和解释 (25)

3.1.4 完整配置 (26)

3.1.5 配置注意事项 (26)

3.2 高级IPv4 ACL 典型配置指导 (27)

3.2.1 组网图 (28)

3.2.2 应用要求 (28)

3.2.3 配置过程和解释 (28)

3.2.4 完整配置 (29)

3.2.5 配置注意事项 (30)

3.3 二层ACL 典型配置指导 (30)

3.3.1 组网图 (31)

3.3.2 应用要求 (31)

3.3.3 配置过程和解释 (31)

3.3.4 完整配置 (31)

3.3.5 配置注意事项 (32)

3.4 用户自定义ACL 和流模板典型配置指导 (32)

3.4.1 组网图 (33)

3.4.2 应用要求 (33)

3.4.3 配置过程和解释 (33)

3.4.4 完整配置 (34)

3.4.5 配置注意事项 (34)

4. IPv6 ACL 典型配置指导 (37)

4.1 基本IPv6 ACL 典型配置指导 (37)

4.1.1 组网图 (37)

4.1.2 应用要求 (37)

4.1.3 配置过程和解释 (37)

4.1.4 完整配置 (38)

4.1.5 配置注意事项 (38)

4.2 高级IPv6 ACL 典型配置指导 (38)

4.2.1 组网图 (39)

4.2.2 应用要求 (39)

4.2.3 配置过程和解释 (39)

4.2.4 完整配置 (40)

4.2.5 配置注意事项 (40)

5. QoS 典型配置指导 (41)

5.1 端口限速和流量监管典型配置指导 (41)

5.1.1 组网图 (41)

5.1.2 应用要求 (41)

5.1.3 配置过程和解释 (42)

5.1.4 完整配置 (43)

5.1.5 配置注意事项 (43)

5.2 优先级重标记和队列调度典型配置指导 (46)

5.2.1 组网图 (46)

5.2.2 应用要求 (46)

5.2.3 配置过程和解释 (47)

5.2.4 完整配置 (48)

5.2.5 配置注意事项 (48)

5.3 优先级映射和队列调度典型配置指导 (50)

5.3.1 组网图 (50)

5.3.2 应用要求 (50)

5.3.3 配置过程和解释 (51)

5.3.4 完整配置 (51)

5.3.5 配置注意事项 (52)

5.4 流镜像和重定向至端口典型配置指导 (55)

5.4.1 组网图 (55)

5.4.2 应用要求 (55)

5.4.3 配置过程和解释 (56)

5.4.4 完整配置 (57)

5.4.5 配置注意事项 (57)

5.5 重定向至下一跳典型配置指导 (58)

5.5.1 组网图 (58)

5.5.2 应用要求 (58)

5.5.3 配置过程和解释 (58)

5.5.5 配置注意事项 (59)

6. 交换机端口链路类型介绍 (60)

6.1 交换机端口链路类型介绍 (60)

6.2 各类型端口使用注意事项 (60)

6.3 各类型端口在接收和发送报文时的处理 (61)

6.4 交换机Trunk 端口配置 (62)

6.4.1 组网需求: (62)

6.4.2 组网图: (62)

6.4.3 配置步骤: (63)

6.5 交换机Hybrid 端口配置 (64)

6.5.1 组网需求: (64)

6.5.2 组网图: (65)

6.5.2 配置步骤: (66)

7. 链路聚合典型配置指导 (70)

7.1 链路聚合典型配置指导 (70)

7.1.1 组网图 (70)

7.1.2 应用要求 (70)

7.1.3 配置过程和解释 (70)

7.1.4 完整配置 (71)

7.1.5 配置注意事项 (71)

7.2 链路聚合典型配置指导 (72)

7.2.1 组网图 (72)

7.2.2 应用要求 (72)

7.2.3 配置过程和解释 (72)

7.2.4 配置注意事项 (73)

8、端口镜像典型配置指导 (73)

8.1 本地端口镜像典型配置指导 (73)

8.1.1 组网图 (73)

8.1.2 应用要求 (74)

8.1.3 配置过程和解释 (74)

8.1.4 完整配置 (74)

8.1.5 配置注意事项 (74)

8.2 远程端口镜像典型配置指导(方式一) (75)

8.2.1 组网图 (76)

8.2.2 应用要求 (76)

8.2.3 配置过程和解释 (76)

8.2.4 完整配置 (77)

8.2.5 配置注意事项 (78)

8.3 远程端口镜像典型配置指导(方式二) (79)

8.3.1 组网图 (80)

8.3.3 配置过程和解释 (80)

8.3.4 完整配置 (81)

8.3.5 配置注意事项 (82)

9.端口隔离典型配置指导 (83)

9.1 端口隔离概述 (83)

9.2 端口隔离配置指导(方式一) (83)

9.2.1 组网图 (83)

9.2.2 配置过程和解释 (84)

9.2.3 配置注意事项 (84)

9.3 端口隔离配置指导(方式二) (84)

9.3.1 组网图 (84)

9.3.2 配置过程和解释 (85)

9.3.3 配置注意事项 (85)

10. LLDP 典型配置指导 (86)

10.1 LLDP 简介 (86)

10.2 LLDP 典型配置指导 (87)

10.2.1 组网图 (87)

10.2.2 应用要求 (87)

10.2.3 配置过程和解释 (87)

10.2.4 完整配置 (89)

10.2.5 配置注意事项 (89)

11. DHCP 典型配置指导 (90)

11.1 DHCP 服务器静态绑定地址典型配置指导 (90)

11.1.1 组网图 (90)

11.1.2 应用要求 (90)

11.1.3 配置过程和解释 (90)

11.1.4 完整配置 (90)

11.1.5 配置注意事项 (91)

11.2 DHCP 服务器动态分配地址典型配置指导 (91)

11.2.1 组网图 (91)

11.2.2 应用要求 (91)

11.2.3 配置过程和解释 (92)

11.2.4 完整配置 (92)

11.2.5 配置注意事项 (93)

11.3 DHCP 中继典型配置指导 (93)

11.3.1 组网图 (94)

11.3.2 应用要求 (94)

11.3.3 配置过程和解释 (94)

11.3.4 完整配置 (95)

11.3.5 配置注意事项 (95)

11.4 DHCP Snooping 典型配置指导 (95)

11.4.1 组网图 (96)

11.4.2 应用要求 (96)

11.4.3 配置过程和解释 (96)

11.4.4 完整配置 (97)

11.4.5 配置注意事项 (97)

11.5 DHCP Snooping 支持Option 82 典型配置指导 (97)

11.5.1 组网图 (98)

11.5.2 应用要求 (98)

11.5.3 配置过程和解释 (98)

11.5.4 完整配置 (100)

11.5.6 配置注意事项 (100)

11.6 自动配置功能典型配置指导 (100)

11.6.1 组网图 (101)

11.6.2 应用需求 (101)

11.6.3 配置过程和解释 (102)

11.6.4 完整配置 (105)

11.6.7 注意事项 (106)

1.登录交换机典型配置指导

1.1 通过 Console 口配置 Telnet 登录方式典型配置指导

通过交换机 Console 口进行本地登录是登录交换机的最基本的方式,也是配置通过其他方式登录 交换机的基础。

1.1.1 组网图

PC

Switch

通过 Console 口配置 Telnet 登录方式的组网图

1.1.2 应用要求

如上组网中,建立本地配置环境,只需将 PC 机(或终端)的串口通过配置电缆与以太网交换机

的 Console 口连接。当前用户通过 Console 口(AUX 用户界面)登录到交换机对 Telnet 登录方式 进行配置,且用户级别为管理级(3 级)。

1.1.3 配置过程和解释

配置 Telnet 登录方式的公共属性

# 进入系统视图,启动 Telnet 服务

# 配置从 VTY 用户界面登录后可以访问的命令级别为 2 级

# 设置 VTY0 用户界面支持 Telnet 协议

[Sysname-ui-vty0] protocol inbound telnet

# 设置 VTY0 用户的终端屏幕的一屏显示 30 行命令

[Sysname-ui-vty0] screen-length 30

# 设置 VTY0 用户历史命令缓冲区可存放 20 条命令

[Sysname-ui-vty0] history-command max-size 20

# 设置 VTY0 用户界面的超时时间为 6 分钟

[Sysname-ui-vty0] idle-timeout 6

通过 Telnet 登录用户的认证方式

Telnet 登录有以下几种认证方式:

认证方式为 None ,认证方式为 Password ,认证方式为 Scheme 。下面我们分别描述这几种认证方 式的配置:

设置通过 VTY0 用户界面登录交换机的 Telnet 用户不需要进行认证

[Sysname] user-interface vty 0

[Sysname] user-interface vty 0

[Sysname-ui-vty0] user privilege level 2 system-view

[Sysname] telnet server enable RS-232串口

Console 口

配置电缆

[Sysname-ui-vty0] authentication-mode none

设置通过VTY0 口登录交换机的Telnet 用户进行Password 认证,并设置用户的认证口令为明文方式,口令为123456

[Sysname] user-interface vty 0

[Sysname-ui-vty0] authentication-mode password

[Sysname-ui-vty0] set authentication password simple 123456

设置登录用户的认证方式为Scheme,采用本地认证的方式

# 创建本地用户guest,并进入本地用户视图

[Sysname] local-user guest

# 设置本地用户的认证口令为明文方式,口令为123456

[Sysname-luser-guest] password simple 123456

# 设置VTY 用户的服务类型为Telnet 且用户级别为2

[Sysname-luser-guest] service-type telnet level 2

[Sysname-luser-guest] quit

# 进入VTY 用户界面视图

[Sysname] user-interface vty 0

# 设置通过VTY0 口登录交换机的Telnet 用户进行Scheme 认证

[Sysname-ui-vty0] authentication-mode scheme

[Sysname-ui-vty0] quit

# 指定system 域为缺省域,并设置该域Scheme 认证方式local

[Sysname] domain default enable system

[Sysname] domain system

[Sysname-isp-system] authentication default local

1.1.4 完整配置

认证方式为None 时Telnet 登录方式的配置

#

telnet server enable

#

user-interface vty 0

authentication-mode none

user privilege level 2

history-command max-size 20

idle-timeout 6 0

screen-length 30

protocol inbound telnet

认证方式为Password 时Telnet 登录方式的配置

#

telnet server enable

#

user-interface vty 0

authentication-mode none

user privilege level 2

set authentication password simple 123456

history-command max-size 20

idle-timeout 6 0

screen-length 30

protocol inbound telnet

认证方式为Scheme 时Telnet 登录方式的配置

#

domain system

authentication default local

#

telnet server enable

#

local-user guest

service-type telnet

level 2

password simple 123456

#

user-interface vty 0

authentication-mode scheme

user privilege level 2

history-command max-size 20

idle-timeout 6 0

screen-length 30

protocol inbound telnet

1.2 通过Telnet 配置Console 口登录方式典型配置指导

交换机支持Telnet 功能,用户可以通过Telnet 方式对交换机进行远程管理和维护。

1.2.1 组网图

GE1/0/1

Ethernet

配置交换机的PC机

运行Telnet

通过Telnet 配置Console 口登录方式的组网图

1.2.2 应用要求

如上组网中,当前用户通过Telnet 方式登录到交换机对Console 口登录方式进行配置,且用户级别为管理级(3 级)。

1.2.3 配置过程和解释

配置Console 口登录方式的公共属性

# 配置从AUX 用户界面登录后可以访问的命令级别为2 级。

[Sysname] user-interface aux 0

[Sysname-ui-aux0] user privilege level 2

# 配置Console 口使用的波特率为19200bit/s

[Sysname-ui-aux0] speed 19200

# 配置终端屏幕的一屏显示30 行命令

[Sysname-ui-aux0] screen-length 30

# 配置历史命令缓冲区可存放20 条命令

[Sysname-ui-aux0] history-command max-size 20

# 配置AUX 用户界面的超时时间为6 分钟

[Sysname-ui-aux0] idle-timeout 6

配置Console 口登录用户的认证方式

Console 口登录有以下几种认证方式:

level 2 认证方式为 None ,认证方式为 Password ,认证方式为 Scheme 。下面我们分别描述这几种认证方 式的配置:

设置登录用户的认证方式为 None

设置登录用户的认证方式为 Password ,并设置用户的认证口令为明文方式,口令为

123456

设置登录用户的认证方式为 Scheme ,采用本地认证的方式

# 创建本地用户 guest ,并进入本地用户视图

[Sysname] local-user guest

# 设置本地用户的认证口令为明文方式,口令为 123456

[Sysname-luser-guest] password simple 123456

# 设置本地用户的服务类型为 Terminal 且用户级别为 2 # 进入 AUX 用户界面视图

[Sysname] user-interface aux 0

# 设置通过 Console 口登录交换机的用户进行 Scheme 认证

[Sysname-ui-aux0] authentication-mode scheme

1.2.4 完整配置

认证方式为 None 时 Console 口登录方式的配置

#

user-interface aux 0

authentication-mode none user privilege level 2

history-command max-size 20 idle-timeout 6 0 speed 19200

screen-length 30

认证方式为 Password 时 Console 口登录方式的配置

#

user-interface aux 0

authentication-mode password user privilege level 2

set authentication password simple 123456 history-command max-size 20 idle-timeout 6 0 speed 19200

screen-length 30

认证方式为 Scheme 时 Console 口登录方式的配置

#

local-user guest

password simple 123456 service-type terminal

#

user-interface aux 0

authentication-mode scheme user privilege level 2

history-command max-size 20 idle-timeout 6 0 speed 19200

screen-length 30

[Sysname-luser-guest] service-type terminal level 2

[Sysname-luser-guest] quit [Sysname] user-interface aux 0

[Sysname-ui-aux0] authentication-mode password

[Sysname-ui-aux0] set authentication password simple 123456 [Sysname] user-interface aux 0

[Sysname-ui-aux0] authentication-mode none

1.3 通过 WEB 网管登录交换机典型配置指导

1.3.1 组网图

Network

Interface

Card

RS-232

Console port

Ethernet port

通过 WEB 网管登录交换机示意图

1.3.2 应用要求

如上组网图所示,PC 通过 WEB 网管登录交换机,实现对交换机的远程管理。

1.3.4 配置过程和解释

# 通过 Console 口正确配置以太网交换机 VLAN 1 接口的 IP 地址(VLAN 1 为交换机的缺省 VLAN ) 为

10.153.17.82,子网掩码为 255.255.255.0。

# 配置 WEB 网管用户名为 admin ,认证口令为 admin ,用户级别为 3 级。

# 开启交换机的 WEB Server 功能。

[Sysname] ip http enable

# 通过浏览器登录交换机:在 WEB 网管终端(PC)的浏览器地址栏内输入 (WEB 网管终端和以太

网交换机之间要路由可达),浏览器会显示 WEB 网管的登录页面,如 WEB 网管 登录页面所示。

H3C交换机最详细配置实例手册

WEB 网管登录页面

# 输入在交换机上添加的用户名和密码,点击<登录>按钮后即可登录,显示 WEB 网管初始页面。

[Sysname] local-user admin

[Sysname-luser-admin] service-type telnet level 3 [Sysname-luser-admin] password simple admin [Sysname-luser-admin] quit system-view

[Sysname] interface vlan-interface 1

[Sysname-VLAN-interface1] ip address 10.153.17.82 255.255.255.0 [Sysname-VLAN-interface1] quit

level 3 1.3.5 完整配置

#

local-user admin

password simple admin service-type telnet

#

interface Vlan-interface1

ip address 10.153.17.82 255.255.255.0

1.3.6 配置注意事项

缺省情况下,WEB 网管功能处于开启状态。

1.4 对登录用户的控制典型配置指导

1.4.1 组网图

10.110.100.46

Host A

Switch

Host B 10.110.100.52

对登录用户的控制典型配置示意图

1.4.2 应用要求

如上组网中,仅允许来自 10.110.100.52 和 10.110.100.46 的 Telnet/SNMP/WEB 用户访问交换机。

1.4.3 配置过程和解释

# 创建并进入基本 ACL 视图 2000

# 定义子规则,仅允许来自 10.110.100.52 和 10.110.100.46 的 T elnet/SNMP/WEB 用户访问交换机

# 引用访问控制列表 2000,通过源 IP 对 Telnet 用户进行控制

# 引用访问控制列表 2000,通过源 IP 对网管用户进行控制

[Sysname] snmp-agent community read aaa acl 2000 [Sysname] snmp-agent group v2c groupa acl 2000

[Sysname] snmp-agent usm-user v2c usera groupa acl 2000 [Sysname] user-interface vty 0 4

[Sysname-ui-vty0-4] acl 2000 inbound [Sysname-acl-basic-2000] rule 1 permit source 10.110.100.52 0

[Sysname-acl-basic-2000] rule 2 permit source 10.110.100.46 0 [Sysname-acl-basic-2000] rule 3 deny source any [Sysname-acl-basic-2000] quit [Sysname] acl number 2000 match-order config [Sysname-acl-basic-2000]

rule 3 deny rule 3 deny # 引用访问控制列表 2000,通过源 IP 对 WEB 用户进行控制

[Sysname] ip http acl 2000

1.4.4 完整配置

对 Telnet 用户进行控制

#

acl number 2000

rule 1 permit source 10.110.100.52 0 rule 2 permit source 10.110.100.46 0

#

user-interface vty 0 4 acl 2000 inbound

通过源 IP 对网管用户进行控制

#

acl number 2000

rule 1 permit source 10.110.100.52 0 rule 2 permit source 10.110.100.46 0

#

snmp-agent community read aaa acl 2000 snmp-agent group v2c groupa acl 2000

snmp-agent usm-user v2c usera groupa acl 2000

通过源 IP 对 WEB 用户进行控制

a #

ip http acl 2000 # cl number 2000

rule 1 permit source 10.110.100.52 0 rule 2 permit source 10.110.100.46 0 rule 3 deny

2. VLAN 典型配置指导

2.1 基于端口的 VLAN 典型配置指导

2.1.1 组网图

Server2

Server1

Host1

Host2

基于端口的 VLAN 组网示意图

2.1.2 应用要求

如基于端口的 VLAN 组网示意图所示,Switch A 和 Switch B 分别连接了不同部门使

用的 Host1/Host2 和 Server1/Server2。 为保证部门间数据的二层隔离,现要求将 Host1 和 Server1 划分到 VLAN100 中,

Host2 和 Server2 划分到 VLAN200 中。并分别为两个 VLAN 设置描述字符为 “Dept1”和“Dept2”。

在 SwitchA 上配置 VLAN 接口,对 Host1 发往 Server2 的数据进行三层转发。

2.1.3 配置过程和解释

配置 Switch A

# 创建 VLAN100,并配置 VLAN100 的描述字符串为“Dept1”,将端口 GigabitEthernet1/0/1 加入

到 VLAN100。

# 创建 VLAN200,并配置 VLAN200 的描述字符串为“Dept2”。

# 创建 VLAN100 和 VLAN200 的接口,IP 地址分别配置为 192.168.1.1 和 192.168.2.1,用来对 Host1

[SwitchA] vlan 200

[SwitchA-vlan200] description Dept2 [SwitchA-vlan200] quit system-view

[SwitchA] vlan 100

[SwitchA-vlan100] description Dept1

[SwitchA-vlan100] port GigabitEthernet 1/0/1 [SwitchA-vlan100] quit SwitchA

GE1/0/12

GE1/0/2

GE1/0/13

GE1/0/1

GE1/0/10

SwitchB GE1/0/11

#

vlan 100

description dept1 #

vlan 200

description dept2 #

interface Vlan-interface 100

ip address 192.168.1.1 255.255.255.0 #

interface Vlan-interface 200

ip address 192.168.2.1 255.255.255.0 #

interface GigabitEthernet1/0/1 port access vlan 100 发往 Server2 的报文进行三层转发。

[SwitchA] interface Vlan-interface 100

[SwitchA-Vlan-interface100] ip address 192.168.1.1 24 [SwitchA-Vlan-interface100] quit

[SwitchA] interface Vlan-interface 200

[SwitchA-Vlan-interface200] ip address 192.168.2.1 24

配置 Switch B

# 创建 VLAN100,并配置 VLAN100 的描述字符串为“Dept1”,将端口 GigabitEthernet1/0/13 加入

到 VLAN100。

# 创建 VLAN200,并配置 VLAN200 的描述字符串为“Dept2”,将端口 GigabitEthernet1/0/11 和

GigabitEthernet1/0/12 加入到 VLAN200。

配置 Switch A 和 Switch B 之间的链路

由于 Switch A 和 Switch B 之间的链路需要同时传输 VLAN100 和 VLAN200 的数据,所以可以配置

两端的端口为 Trunk 端口,且允许这两个 VLAN 的报文通过。 # 配置 Switch A 的 GigabitEthernet1/0/2 端口。

# 配置 Switch B 的 GigabitEthernet1/0/10 端口。

2.1.4 完整配置

SwitchA 上的配置

#

interface GigabitEthernet1/0/2 port link-type trunk

port trunk permit vlan 1 100 200

SwitchB 上的配置

#

vlan 100

description dept1 #

vlan 200 [SwitchB] interface GigabitEthernet 1/0/10

[SwitchB-GigabitEthernet1/0/10] port link-type trunk

[SwitchB-GigabitEthernet1/0/10] port trunk permit vlan 100 200 [SwitchA] interface GigabitEthernet 1/0/2

[SwitchA-GigabitEthernet1/0/2] port link-type trunk

[SwitchA-GigabitEthernet1/0/2] port trunk permit vlan 100 200 [SwitchB] vlan 200

[SwitchB-vlan200] description Dept2

[SwotchB-vlan200] port GigabitEthernet1/0/11 GigabitEthernet 1/0/12 [SwitchB-vlan200] quit system-view

[SwitchB] vlan 100

[SwitchB-vlan100] description Dept1

[SwitchB-vlan100] port GigabitEthernet 1/0/13 [SwitchB-vlan100] quit

port trunk permit vlan 1 100 200 #

interface GigabitEthernet1/0/11 port access vlan 100 #

interface GigabitEthernet1/0/12 port access vlan 200 VLAN100

VLAN200

GE1/0/13 GE1/0/14

GE1/0/3

Core switch

GE1/0/4

GE1/0/2

GE1/0/2

chA GE1/0/1

Swi GE1/0/1

i

#

interface GigabitEthernet1/0/13 port access vlan 100

2.2 基于 MAC 的 VLAN 典型配置指导

2.2.1 组网图

Server1

Server2

Swit tchB

Laptop1

Laptop2

基于 MAC 的 VLAN 组网示意图

2.2.2 应用要求

如基于 MAC 的 VLAN 组网示意图所示,SwitchA 和 SwitchB 的 GigabitEthernet1/0/1

端口分别连接到两个会议室,Laptop1 和 Laptop2 是会议用笔记本电脑,会在 两个会议室间移动使用。

Laptop1 和 Laptop2 分别属于两个部门,两个部门间使用 VLAN100 和 VLAN200 进

行隔离。现要求这两台笔记本电脑无论在哪个会议室使用,均只能访问自己部 门的服务器,即 Server1 和 Server2。

Laptop1 和 Laptop2 的 MAC 地址分别为 000d-88f8-4e71、0014-222c-aa69。

2.2.3 配置过程和解释

SwitchA 的配置

description dept2 # nterface GigabitEthernet1/0/10 port link-type trunk

# 创建VLAN100 和VLAN200,并将GigabitEthernet1/0/2 配置为Trunk 端口,允许VLAN100 和VLAN200 的报文通过。

system-view

[SwitchA] vlan 100

[SwitchA-vlan100] quit

[SwitchA] vlan 200

[SwitchA-vlan200] quit

[SwitchA] interface GigabitEthernet1/0/2

[SwitchA-GigabitEthernet1/0/2] port link-type trunk

[SwitchA-GigabitEthernet1/0/2] port trunk permit vlan 100 200

[SwitchA-GigabitEthernet1/0/2] quit

# 将GigabitEthernet1/0/1 配置为Hybrid 端口,并使其在发送VLAN100 和VLAN200 的报文时去掉VLAN Tag。

[SwitchA] interface GigabitEthernet1/0/1

[SwitchA-GigabitEthernet1/0/1] port link-type hybrid

[SwitchA-GigabitEthernet1/0/1] port hybrid vlan 100 200 untagged

[SwitchA-GigabitEthernet1/0/1] quit

# 创建Laptop1 的MAC 地址与VLAN100 的关联,创建Laptop2 的MAC 地址与VLAN200 的关联,开启GigabitEthernet1/0/1 端口的MAC-VLAN 功能。

[SwitchA] mac-vlan mac-address 000d-88f8-4e71 vlan 100

[SwitchA] mac-vlan mac-address 0014-222c-aa69 vlan 200

[SwitchA] interface GigabitEthernet 1/0/1

[SwitchA-GigabitEthernet1/0/1] mac-vlan enable

SwitchB 的配置

SwitchB 的配置与SwitchA 完全一致,这里不再赘述。

Core Switch 的配置

# 创建VLAN100 和VLAN200,并将GigabitEthernet1/0/13 和GigabitVLANEthernet

1/0/14 端口分别加入这两个VLAN。

system-view

[CoreSwitch] vlan 100

[CoreSwitch-vlan100] port gigabitethernet 1/0/13

[CoreSwitch-vlan100] quit

[CoreSwitch] vlan 200

[CoreSwitch-vlan200] port gigabitethernet 1/0/14

[CoreSwitch-vlan200] quit

# 配置GigabitEthernet1/0/3 和GigabitEthernet1/0/4 端口为Trunk 端口,均允许VLAN100 和VLAN200 的报文通过。

[CoreSwitch] interface GigabitEthernet1/0/3

[CoreSwitch-GigabitEthernet1/0/3] port link-type trunk

[CoreSwitch-GigabitEthernet1/0/3] port trunk permit vlan 100 200

[CoreSwitch-GigabitEthernet1/0/3] quit

[CoreSwitch] interface GigabitEthernet1/0/4

[CoreSwitch-GigabitEthernet1/0/4] port link-type trunk

[CoreSwitch-GigabitEthernet1/0/4] port trunk permit vlan 100 200

[CoreSwitch-GigabitEthernet1/0/4] quit

2.2.4 完整配置

SwitchA 的配置

#

mac-vlan mac-address 000d-88f8-4e71 vlan 100 priority 0

mac-vlan mac-address 0014-222c-aa69 vlan 200 priority 0

#

vlan 100

#

vlan 200

#

#

interface GigabitEthernet1/0/1

port link-type hybrid

port hybrid vlan 1 100 200 untagged mac-vlan enable #

vlan 100 #

vlan 200 #

interface GigabitEthernet1/0/3 port link-type trunk

port trunk permit vlan 1 100 200 port access vlan 100

#

interface GigabitEthernet1/0/2 port link-type trunk

port trunk permit vlan 1 100 200

SwitchB 的配置与 SwitchA 完全一致,这里不再赘述。

Core Switch 的配置

#

interface GigabitEthernet1/0/4 port link-type trunk

port trunk permit vlan 1 100 200 #

interface GigabitEthernet1/0/13

#

interface GigabitEthernet1/0/14 port access vlan 200

2.2.5 配置注意事项

基于 MAC 的 VLAN 只能在 Hybrid 端口上配置。

2.3 基于协议的 VLAN 典型配置指导

2.3.1 组网图

IPv4 server

IPv6 server

Office

Lab

基于协议的 VLAN 组网示意图

GE1/0/11 GE1/0/12 GE1/0/1

GE1/0/2

IPv4 Host IPv6 Host IPv6 Host IPv4 Host

#

vlan 100

protocol-vlan 0 ipv4 #

vlan 200

protocol-vlan 0 ipv6 port hybrid protocol-vlan vlan 100 0 port hybrid protocol-vlan vlan 200 0 #

2.3.2 应用要求

如基于协议的 VLAN 组网示意图所示,通过配置交换机的协议 VLAN 功能,使办公区和实验室中 基于 IPv4 网络和基于 IPv6 网络的主机能分别与处在不同 VLAN 内的对应服务器进行通信,且两 种网络协议的报文能够通过 VLAN 进行隔离,其中 IPv4 网络使用 VLAN100,IPv6 网络使用 VLAN200。

2.3.3 配置过程和解释

上行端口的配置

# 创建 VLAN100,将端口 GigabitEthernet1/0/11 加入 VLAN100

# 创建 VLAN200,将端口 GigabitEthernet1/0/12 加入 VLAN200

配置协议模板并与下行端口绑定

# 创建 VLAN200 和 VLAN100 的协议模板,分别匹配 IPv4 和 IPv6 协议。

# 配置端口 GigabitEthernet1/0/1 为 H ybrid 端口,并在转发 VLAN100 和 VLAN200 的报文时去掉 VLAN

Tag 。

# 配置端口 GigabitEthernet1/0/1 分别与 VLAN100 的协议模板 0,VLAN200 的协议模板 0 进行绑定。

# 同理配置端口 GigabitEthernet1/0/2 为 Hybrid 端口,在转发 VLAN100 和 VLAN200 的报文时去掉 VLAN Tag ,并与 VLAN100 和 VLAN200 的协议模板 0 进行绑定

2.3.4 完整配置

#

interface GigabitEthernet1/0/1 port link-type hybrid

port hybrid vlan 1 100 200 untagged

[Sysname] interface GigabitEthernet 1/0/2

[Sysname-GigabitEthernet1/0/2] port link-type hybrid

[Sysname-GigabitEthernet1/0/2] port hybrid vlan 100 200 untagged [Sysname-GigabitEthernet1/0/2] port hybrid protocol-vlan vlan 100 0 [Sysname-GigabitEthernet1/0/2] port hybrid protocol-vlan vlan 200 0 [Sysname-GigabitEthernet1/0/1] port hybrid protocol-vlan vlan 100 0

[Sysname-GigabitEthernet1/0/1] port hybrid protocol-vlan vlan 200 0 [Sysname] interface GigabitEthernet 1/0/1

[Sysname-GigabitEthernet1/0/1] port link-type hybrid

[Sysname-GigabitEthernet1/0/1] port hybrid vlan 100 200 untagged [Sysname-vlan200] protocol-vlan ipv6 [Sysname-vlan200] quit [Sysname-vlan100]

[Sysname-vlan100] protocol-vlan ipv4 [Sysname-vlan100] quit [Sysname-vlan100] quit [Sysname] vlan 200

[Sysname-vlan200] port GigabitEthernet 1/0/12 system-view

[Sysname] vlan 100

[Sysname-vlan100] port GigabitEthernet 1/0/11

下载文档原格式(Word原格式,共106页)
相关文档
  • h3c交换机常用配置

  • h3c交换机配置手册

  • h3c交换机初始配置

  • h3c交换机配置教程